If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 599854
7 years ago
7 years ago

People

(Reporter: Thorsten Roggendorf, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

The RegExp in the URL fails to match. It matches in IE and WebKit browser AND in Firefox up to and including 4.0 beta 9. The problem was introduced with the beta 10 build. The problem was also observed on Vista.

Reproducible: Always

Steps to Reproduce:
Enter this in address bar and hit return:
javascript:'[starts-with(UCPTname,"p/LAN/")]'.match(new RegExp('\\[([^\\(\\n=]+)\\([\\t ]*(@?)([^,\\s]+)[\\t ]*,[\\t ]*()(' + "'" + '|"|\\/)((?:.(?:\\\\\\5|(?!\\5)))*.)\\5([gim]{0,3})[\\t ]*\\)\\]'))
Actual Results:  
null

Expected Results:  
[starts-with(UCPTname,"p/LAN/")],starts-with,,UCPTname,,",p/LAN/,

Updated

7 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general

Comment 1

7 years ago
WFM , evaluate in the error console. 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre ID:20110204030345
Thanks for the report. Confirmed broken in beta 10, but it works in the latest nightly build. Please reopen if you still see this in beta 11.

FWIW I reduced it to this:

javascript:'"abcdef"'.match(/(")((?:.(?:(?!\1)))*.)\1/)

I think this is bug 599854
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599854
You need to log in before you can comment on or make changes to this bug.