"Could not initialise WebGL, sorry :-(" in a virtual machine

RESOLVED INVALID

Status

()

Core
Canvas: WebGL
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: camd, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b11][fx4-fixed-bugday], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
This worked fine on my mac, but on Windows 7 in a VM, it won't even load the
demo.
I get an error dialog saying:

Could not initialise WebGL, sorry :-(

In beta 10, it is able to at least load the demo and start.

Reopening as this is a regression.
(Reporter)

Updated

7 years ago
Created attachment 509837 [details]
Screenshot of error
Whiteboard: [4b11] → [4b11][fx4-fixed-bugday]
Can you paste the graphics section in about:support?

If you're using a Intel card, you need either to install the DirectX runtime or to wait for bug 630628 to land.
Oh, you said in a VM --- we are now blacklisting everything else than Intel, ATI, NVIDIA. The graphics engine in a VM typically shows up as a separate vendor, hence gets blacklisted. This is wanted: we had to blacklist VirtualBox because of crashes, bug 621411.
(Reporter)

Comment 4

7 years ago
Should the message be something more like, "Sorry, your hardware configuration is not supported." or something like that?

Or is this just a bug that should be closed as invalid or wontfix?
(In reply to comment #4)
> Should the message be something more like, "Sorry, your hardware configuration
> is not supported." or something like that?

I think the bug is valid -- we should deliver a better message (at least one without emoticons)
(In reply to comment #5)
> (In reply to comment #4)
> > Should the message be something more like, "Sorry, your hardware configuration
> > is not supported." or something like that?
> 
> I think the bug is valid -- we should deliver a better message (at least one
> without emoticons)

The message here is delivered by the website authors, not by us.

More information is available in about:support (currently only for Direct2D but soon generalized to all features) and available to privileged content using the nsIGfxInfo interface.

Comment 7

7 years ago
Per comment 4, I close it as invalid.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Updated

7 years ago
Summary: Could not initialise WebGL, sorry :-( → "Could not initialise WebGL, sorry :-(" in a virtual machine
You need to log in before you can comment on or make changes to this bug.