Firefox closes but stays in memory. Shutdown hang

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: John Yurco, Unassigned)

Tracking

({hang})

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-03-15])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0C)

Since I upgraded to Windows 7, When I close Firefox it stay in memory. This was initially discovered when I tried restarting it (and therefore may have a relationship to Bug 587917). 

I later discovered that not only did it stay in memory but was using large amounts of processor time (about 50% of my Centrino T5450 dual) and continued to gobble memory.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox.
2. Do anything.
3. Close Firefox.
4. Open Windows Task Manager: Firefox does not show in the "Applications" window but is present under "Processes" as firefox.exe is still running and never seems to stop. 
Actual Results:  
Temporarily solution: In Windows Task Manager highlight "firefox.exe" and with right mouse button select "End Process Tree". This results in a potential data loss warning but I have never lost data. Firefox can now be restarted normally. 

Expected Results:  
Firefox should close in an orderly fashion and vacate memory.
works for me with Firefox 3.6.13, Firefox 4.0 beta 10 and Seamonkey trunk on Windows 7

Do you still see the issue if you start Firefox in the Firefox safemode ?
http://support.mozilla.com/en-US/kb/Safe+Mode

Comment 2

7 years ago
Mine does not gobble memory. Firefox closes well, and leaves no processes running.
Most likely an extension causing this.
Hardware: Other → x86
Version: unspecified → 3.6 Branch
(Reporter)

Comment 4

7 years ago
Recently upgraded to Firefox 3.6.15 and problem persists (although if I do something simple in Firefox and then get out it will close correctly. In version 3.6.15 it does not seem to gobble memory.

Comment 5

7 years ago
I have Windows XP Pro SP3.  Just got new copy of Firefox 5.0.  Every time I have tried to start it up (ok, 5 or 6 times), it says it is already running.  When I check with Task Manager, I can kill the firefox.exe process and can then start it again.  Exit, it stays in memory.  I haven't rebooted since installing, not that I particularly want to.  All previous versions I have have worked fine on this system.  I upgraded just a few days ago.

Comment 6

6 years ago
John, does this happen in version 10?
Severity: normal → critical
Keywords: hang
Summary: Firefox closes but stays in memory → Firefox closes but stays in memory. Shutdown hang
Whiteboard: [closeme 2012-03-15]
(Reporter)

Comment 7

6 years ago
Wayne, Just installed version 10 -- After closing Firefox shows under "processes" for a very short period then terminates. It seems appropriate to close this bug.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.