Last Comment Bug 631648 - [canvas] URL causes Firefox to be extremely unresponsive for well over a minute
: [canvas] URL causes Firefox to be extremely unresponsive for well over a minute
Status: VERIFIED FIXED
[fixed in bug 620216]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla6
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.bbc.co.uk/news/world-middl...
Depends on: 600390
Blocks: slowui
  Show dependency treegraph
 
Reported: 2011-02-04 13:18 PST by Gavin C. Flower
Modified: 2011-07-28 07:00 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Gavin C. Flower 2011-02-04 13:18:45 PST
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre

problems exists for both
    firefox 3.6.13 (Fedora 14 x86_64 distribution version)
and
    firefox-4.0b12pre.en-US.linux-x86_64
    build: 20110202162900

With only one Firefox window with the single tab with the URL:
    http://www.bbc.co.uk/news/world-middle-east-12340082

The desktop in general, and Firefox in particular becomes extremely
unresponsive for well over a minute!

I have tried this several times, and each time the system becomes painfully
slow in the extreme.

Processor utilisation of 2 out of 4 cores goes up to the equivalent of 100%
utilization of one core - top tells me that xorg is running at 99.4%. 

This may be an xorg problem, but because it only appears to happens when I run
Firefox with the URL, I'm raising the bug here.  Other people may have the
same problem and automatically blame Firefox.  Anyhow, mozilla should be aware
of it.

I will also raise a bug on xorg as requested by Boris Zbarsky see Comment 4 of Bug 591821.

Same problem persists in safe mode with all add-ons disabled using:
    firefox-4.0b12pre.en-US.linux-x86_64
    build: 20110202162900

Reproducible: Always

Steps to Reproduce:
1.enter http://www.bbc.co.uk/news/world-middle-east-12340082
2.hit enter 
3.wait...
Actual Results:  
system becomes painfully
slow in the extreme for well over a minute

Expected Results:  
System should still be responsive and should take less than a minute to render or at least not cause such high processor utilisation.

$ uname -a
Linux saturn 2.6.35.10-74.fc14.x86_64 #1 SMP Thu Dec 23 16:04:50 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

up to date Fedora 14 install
AMD 810 quad core 64 bit
8 GB DDR3 RAM
5 * 500GB in software RAID-6 configuration
ASUS M4A78T-E motherboard
Bus 001 Device 004: ID 046d:0990 Logitech, Inc. QuickCam Pro 9000
Comment 1 Gavin C. Flower 2011-02-04 14:03:32 PST
see also: https://bugzilla.redhat.com/show_bug.cgi?id=675326
Comment 2 Karl Tomlinson (ni?:karlt) 2011-02-04 18:10:41 PST
Are you by chance using the xorg-x11-drv-ati video driver?

If so, it looks like Fedora 14 is still on version 6.13.1
http://koji.fedoraproject.org/koji/packageinfo?packageID=95
Version 6.13.2 vastly improves the very slow RepeatNone scaling with KMS.  Unfortunately it looks difficult to try the Fedora 15 packages on a Fedora 14 system.
Comment 3 Gavin C. Flower 2011-02-04 20:11:40 PST
Linux neptune 2.6.34.7-66.fc13.x86_64 #1 SMP Wed Dec 15 07:04:30 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

Fully patched Fedora 14

1.5GB RAM
AMD Sempron(tm) Processor 3000+
single 64 bit core

firefox-4.0b12pre.en-US.linux-x86_64
build: 20110202162900

Same problems with unresponsiveness and overloaded processor
Comment 4 Gavin C. Flower 2011-02-04 20:15:37 PST
Sorry, the last comment should have said Fedora 13
Comment 5 Karl Tomlinson (ni?:karlt) 2011-02-04 20:31:37 PST
What video driver is X using?
(I expect xorg-x11-drv-ati 6.13.0 would have the same issue if using kms.)
I see sluggish scrolling here, but not like described in comment 0.
Comment 6 Gavin C. Flower 2011-02-04 21:06:35 PST
on saturn the quad core AMD with Fedora 14:
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3300 Graphics

on neptune the single core AMD Sempron wirh Fedora 13:
from /var/log/Xorg.0.log
[    38.611] (--) NOUVEAU(0): Chipset: "NVIDIA NV4a"

I will investigate xorg-x11-drv-ati later - we are about to have visitors for
dinner, so it might be 3 or more hours before I can report back...

Not sure how to check the video driver
Comment 7 Karl Tomlinson (ni?:karlt) 2011-02-04 21:15:17 PST
Thanks.  Interesting that nouveau has the same issue.
xorg-x11-drv-ati reports as "radon" in Xorg.0.log.
Comment 8 Karl Tomlinson (ni?:karlt) 2011-02-04 21:15:33 PST
"radeon", that is.
Comment 9 Gavin C. Flower 2011-02-05 01:07:07 PST
on saturn the quad core AMD with Fedora 14:
[    23.460] (II) LoadModule: "radeon"
[    23.460] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[    23.460] (II) Module radeon: vendor="X.Org Foundation"
[    23.460]    compiled for 1.8.99.906, module version = 6.13.99
[    23.460]    Module class: X.Org Video Driver
[    23.460]    ABI class: X.Org Video Driver, version 8.0
Comment 10 Karl Tomlinson (ni?:karlt) 2011-02-05 11:32:13 PST
Maybe the version is reported as 6.13.99 because they didn't expect to do a 6.13.2 release.  For 6.13.2, the version was changed from 6.13.99 to 6.13.2.
http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=cc5005af61f45a3552f7358dc5aa711e42f5af54

I checked the source of http://koji.fedoraproject.org/koji/buildinfo?buildID=192343 and it doesn't have the fix for the issue in comment 2.  (i.e. http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=f8fb9312d791af1f77020e8c2d35bb30841ed9aa)

FWIW, I expect fixing bug 600390 would vastly improve this for both radeon and nouveau drivers.
Comment 11 Gavin C. Flower 2011-02-05 14:33:46 PST
Curious, yum reports version as '6.13.1' rather than as '6.13.99'!

# yum info xorg-x11-drv-ati
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Adding en_GB to language list

Found 154 installed debuginfo package(s)
Enabling rpmfusion-free-updates-debuginfo: RPM Fusion for Fedora 14 - Free - Updates Debug
Enabling rpmfusion-nonfree-updates-debuginfo: RPM Fusion for Fedora 14 - Nonfree - Updates Debug
Enabling rpmfusion-free-debuginfo: RPM Fusion for Fedora 14 - Free - Debug
Installed Packages
Name        : xorg-x11-drv-ati
Arch        : x86_64
Version     : 6.13.1
Release     : 0.3.20100705git37b348059.fc14
Size        : 1.1 M
Repo        : installed
From repo   : anaconda-InstallationRepo-201010211827.x86_64
Summary     : Xorg X11 ati video driver
URL         : http://www.x.org
License     : MIT
Description : X.Org X11 ati video driver.
Comment 12 Karl Tomlinson (ni?:karlt) 2011-05-18 17:31:33 PDT
I expect this is resolved by
http://hg.mozilla.org/mozilla-central/rev/4b8d96e463fd
Comment 13 Vlad [QA] 2011-07-28 07:00:40 PDT
Setting resolution to Verified Fixed on Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0b3

Note You need to log in before you can comment on or make changes to this bug.