updater stopped working on Minefield b11pre (while b12pre is out)

RESOLVED INVALID

Status

defect
RESOLVED INVALID
9 years ago
6 years ago

People

(Reporter: LogosZer0, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

I had no idea what was going on, no update on Minefield since February 2. Just had a look at Minefield web site and found that a b12pre was out. Not a problem I'll update manually now but well, something went wrong with the updater it seems... I don't even know if a first build of this b12pre was already out yesterday. Again it doesn't matter, that was just to mention the updater issue... unless that was wanted... no idea.

Reproducible: Sometimes

Steps to Reproduce:
1.check for update on b11pre
2.
3.
Actual Results:  
Minefield is up to date ???
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Version: unspecified → Trunk
Did you already manually install the new version?
Reporter

Comment 2

9 years ago
yes
Without your system being in the state where it isn't working there isn't anything we can do to try to figure this out besides checking if updates are working which they are. Resolving -> Incomplete because of this but if you are able to reproduce please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INCOMPLETE
Reporter

Comment 4

9 years ago
okay I could reproduce. Luckily I had a copy of the setup from Jan 31 (b11pre), installed it checked for update and it updated to February 02 (b11pre) and now it's stuck again on that build with no update - apparently - available.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Reporter

Comment 5

9 years ago
if you need a file in my install, feel free to let me know while I'm still on this build ;)
Just noticed the bug platform field is X86_64. The 64 bit Windows builds haven't been producing updates which is why you aren't getting updated. We aren't releasing a 64 bit build on Windows of Firefox 4.0 so it isn't a priority to fix at the moment.

btw: Windows 64 bit support isn't complete yet - see bug 568949 comment #29 for workarounds.

Moving over to releng.
Component: Application Update → Release Engineering
Product: Toolkit → mozilla.org
QA Contact: application.update → release
Version: Trunk → other
Reporter

Comment 7

9 years ago
no no, my bad I indicated 64 bit to mention my OS version (W7/64). I do use Minefield 32!!! :)
Reporter

Comment 8

9 years ago
... anyway I wasn't wrong, the box asks about the Windows platform, not the Minefield architecture.
Are you positive? I have a 64 bit build and it only updates to February 2nd which is the same date you indicated and I also have a 32 bit build and it is updating without any problems.
I believe this is intentional.

See bug 631028.  For the latest betas, we've been disabling nightly updates for a few days to get nightly testing of the same code that's in the beta.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → INVALID
Reporter

Comment 11

9 years ago
no I'm not... sorry for all the fuss... just noticing now that the build manually downloaded on Jan 31 was a 64 build indeed. I wasn't aware of it at all, i.e. I always used 32 bit versions so far, had to re-install Minefield from scratch for some reason and picked up the 64 bit build, i.e. not purposely. Again, sorry for wasting your time here guys ;)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → INVALID
Reporter

Comment 12

9 years ago
no I'm not... sorry for all the fuss... just noticing now that the build manually downloaded on Jan 31 was a 64 build indeed. I wasn't aware of it at all, i.e. I always used 32 bit versions so far, had to re-install Minefield from scratch for some reason and picked up the 64 bit build, i.e. not purposely. Again, sorry for wasting your time here guys ;)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Please stop changing the status. If you need help with dealing with the accidental install of the 64 bit version please use http://support.mozilla.com or ask at http://forums.mozillazine.org
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → INVALID
Reporter

Comment 14

9 years ago
I didn't double post purposely, and I didn't change the status again. Help about what now ??? that was a wrong download my bad end of story ;)
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.