Last Comment Bug 631705 - profiling membuster
: profiling membuster
Status: RESOLVED INCOMPLETE
[MemShrink:P3]
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 631578 MemShrinkTools
  Show dependency treegraph
 
Reported: 2011-02-04 15:50 PST by Robert Sayre
Modified: 2014-01-20 21:03 PST (History)
23 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
my printfs for logging (2.76 KB, patch)
2011-02-04 16:02 PST, Robert Sayre
no flags Details | Diff | Review

Description Robert Sayre 2011-02-04 15:50:55 PST
an instrumented copy of membuster lives here:
http://people.mozilla.com/~sayrer/2011/membuster.html

http://people.mozilla.com/~sayrer/2011/02/membuster-stats/linux3.6.html
http://people.mozilla.com/~sayrer/2011/02/membuster-stats/linux-mc.html

These stats show that m-c is carrying 50-100 DOMWindows more than 3.6, and m-c leaves 200 DOMWindows around after the run has completed. The detailed m-c stats show that image-data, mjit code, and layout (to a lesser extent) are the bigger bits. js/gc-heap doesn't shrink.

Unfortunately, these stats don't yet account for the full browser's memory usage. The builds are debug anyway. I want to add total counts of JSObjects, and the size of the Cycle Collector graph.

This page is run with these prefs:

browser.dom.window.dump.enabled;true
dom.popup_maximum;700

and people.mozilla.com is allowed to open popups.
Comment 1 Robert Sayre 2011-02-04 15:51:48 PST
I should add, I also keep an altered copy of about:memory open during the run. It runs in a 10 second setTimeout, so I can track the stats over time.
Comment 2 Robert Sayre 2011-02-04 16:02:50 PST
Created attachment 509931 [details] [diff] [review]
my printfs for logging
Comment 3 Robert Sayre 2011-02-04 16:11:42 PST
the WIP python analysis scripts. it processes the stdout/stderr of a debug browser build running membuster (or anything, I guess) and makes graphs.

http://hg.mozilla.org/users/rsayre_mozilla.com/membuster-analysis
Comment 4 Nicholas Nethercote [:njn] 2011-06-10 09:31:33 PDT
Unfortunately the URLs in comment 0 no longer work because Sayre's page is gone.  The python scripts in comment 3 are still available.
Comment 5 nemo 2011-06-23 17:57:50 PDT
http://webcache.googleusercontent.com/search?q=cache:-JlKDPLKEZUJ:people.mozilla.com/~sayrer/2011/membuster.html

Rehosted http://m8y.org/tmp/membuster.html

Seems to be self-contained. Could probably be attached to the bug.
Comment 6 Nicholas Nethercote [:njn] 2014-01-20 21:03:52 PST
This bug isn't useful any more.

Note You need to log in before you can comment on or make changes to this bug.