Preference window has no title bar, and is floating in space

RESOLVED DUPLICATE of bug 641288

Status

()

RESOLVED DUPLICATE of bug 641288
8 years ago
6 years ago

People

(Reporter: justdave, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

In the last couple nightlies, the preferences window appears to have become a sheet instead of a separate window, however it's attached to the hidden offscreen fake window instead of one of the real ones, which causes said hidden window to move onscreen and become visible in order for the sheet to pop out of it.  There is no way to move it around on the screen to get it out of the way of something else, because the hidden window has no title bar.  Upon closing it (by hitting OK or Cancel at the bottom), it retreats back into the hidden window, which remains visible, frontmost, and unable to be moved, in a 100x100 (or thereabouts) block in the upper left corner of the screen, until you quit the app.

I'm hoping this was changed to a sheet instead of a standalone window on accident (but I kind of doubt it because of the existence of OK and Cancel buttons rather than a close box) because I often leave it open so I can change a pref back and forth while working on something in a web page.  Or at least have it become a tab like most of the other dialogs seem to be becoming.
Dave - I can't reproduce this on latest nightly - can you still see it? Do you see it on a clean profile?

-'ng pending more STR.
blocking2.0: ? → -
Yeah, I launch in safe mode and it still happens.  In fact, when launched in safe mode it opens mostly offscreen and I can't get to half the window.  Since I have to do console to get safe mode, I also notice the following in the console output:

> Tue Feb  8 20:33:34 device-df1799 firefox-bin[48666] <Error>: kCGErrorIllegalArgument: _CGSFindSharedWindow: WID -1
> Tue Feb  8 20:33:34 device-df1799 firefox-bin[48666] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
> Tue Feb  8 20:33:34 device-df1799 firefox-bin[48666] <Error>: kCGErrorIllegalArgument: CGSCopyWindowProperty
> Tue Feb  8 20:33:34 device-df1799 firefox-bin[48666] <Error>: kCGErrorIllegalArgument: CGSGetWindowProperty
> Tue Feb  8 20:33:34 device-df1799 firefox-bin[48666] <Error>: kCGErrorIllegalArgument: windowGroup: error getting ordering group property

which shows up about the same time I try to open the preferences window from the Minefield menu.
Launching the app with a new profile makes it go away.  So something in my profile not affected by safe mode....  any ideas?
OK, with a little poking around I managed to disable this and re-enable it again so now I have STR :)

1) go to about:config
2) set browser.preferences.instantApply to false
3) open Preferences from the Minefield menu

Results: It opens as a sheet from the "hidden" window with no other chrome on it.

4) close preferences window by clicking OK or Cancel
5) go to about:config
6) set browser.preferences.instantApply to true
7) open Preferences from the Minefield menu

Results: it opens as a separate window like it used to.

I'm not sure how that pref got twiddled that way or even if it's important that the preferences window work with it off.  I'm setting it to true now and leaving it that way because it seems more Mac-like. ;)

Comment 5

7 years ago
There are add-ons that need the OK and CANCEL buttons that are only available when instantApply is set FALSE on Macs. This bug has been around for quite a while.

Comment 6

7 years ago
(In reply to Dave Miller [:justdave] from comment #4)
> OK, with a little poking around I managed to disable this and re-enable it
> again so now I have STR :)
> 
> 1) go to about:config
> 2) set browser.preferences.instantApply to false
> 3) open Preferences from the Minefield menu
> 
> Results: It opens as a sheet from the "hidden" window with no other chrome
> on it.
> 
> 4) close preferences window by clicking OK or Cancel
> 5) go to about:config
> 6) set browser.preferences.instantApply to true
> 7) open Preferences from the Minefield menu
> 
> Results: it opens as a separate window like it used to.
> 
> I'm not sure how that pref got twiddled that way or even if it's important
> that the preferences window work with it off.  I'm setting it to true now
> and leaving it that way because it seems more Mac-like. ;)

Some add-ons require the OK and Cancel buttons for their windows to work properly. Firefox-on-Mac does not provide these buttons by default. Setting instantApply false allows these add-ons to work.

This is the same bug as 641288.

Comment 7

6 years ago
This seems very related to Bug 679253.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 679253
Er, whoops
Duplicate of bug: 641288
You need to log in before you can comment on or make changes to this bug.