Cairo compilation failure with Windows 7 and 7.1 SDK

RESOLVED DUPLICATE of bug 579159

Status

()

Core
Build Config
--
major
RESOLVED DUPLICATE of bug 579159
7 years ago
7 years ago

People

(Reporter: gkw, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 510026 [details]
log

Firefox fails to compile properly with pymake and MozillaBuild 1.5.1, Visual Studio 2008 Express with the Win7 SDK installed, including the Windows Server 2003 R2 requirement and the DirectX SDK (June 2010) ones as well.

Occurs on mozilla-central rev f2a6a78478dc. I'm not sure if it's an error on my side, but js shells seem to compile successfully. Feel free to move away from Firefox General as it's 2am my side and time for bed.

I created an objdir in the m-c source tree, changed into the objdir, then ran this command:

python -O ../build/pymake/make.py -s -j2 -f ../client.mk

.mozconfig:

. $topsrcdir/browser/config/mozconfig
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-ff-dbg-32-mc
mk_add_options MOZ_MAKE_FLAGS="-s -j2"
ac_add_options --enable-debug
ac_add_options --disable-optimize
ac_add_options --enable-tests

Comment 1

7 years ago
c:\program files\microsoft sdks\windows\v7.1\include\ocidl.h(6385) : error C2061: syntax error : identifier '__RPC__inout_xcount'

Does it work if you compile with 'make' instead? This sounds like an SDK issue of some sort.
(Reporter)

Comment 2

7 years ago
Created attachment 510076 [details]
with make

Also occurs with make
(Reporter)

Comment 3

7 years ago
No idea who else I should cc..
Summary: Cairo compilation failure with pymake, Windows 7 and 7.1 SDK → Cairo compilation failure with Windows 7 and 7.1 SDK
(Reporter)

Comment 4

7 years ago
At the Windows SDK configuration tool, I have v7.1 and v6.0A installed, with v7.1 selected:

Version: v7.1
Name: Microsoft Windows SDK for Windows 7 (7.1.7600.0.30514)
Install Folder: C:\Program Files\Microsoft SDKs\Windows\v7.1\

Installed Components:
Windows SDK Tools for .NET Framework 4.0
Windows SDK Tools for .NET Framework 4.0 (x64)
Windows SDK Tools for .NET Framework 4.0
Microsoft Windows SDK Headers and Libraries
Microsoft Windows SDK Intellisense for .Net
Windows SDK Intellisense and Reference Assemblies
Microsoft Windows SDK NetFx Interop
Microsoft Windows SDK NetFx 3.5 Tools
Microsoft Windows SDK NetFx 3.5 Tools (x64)
Windows SDK Samples
Windows SDK Common Utilities
Windows SDK Common Utilities (x64)
Windows SDK Utilities for Win32 Development
Windows SDK Utilities for Win32 Development (x64)

Comment 5

7 years ago
This appears to be a bug in the Windows headers, or incompatibility with this version of MSVC, or something. Can you poke around and figure out where __RPC__inout_xcount is normally defined (I think it's a static analysis annotation that Microsoft uses), and see if we can work around the issue by including something else?
Component: General → Build Config
Product: Firefox → Core
QA Contact: general → build-config
(Reporter)

Comment 6

7 years ago
I'm going to try this:

http://forums.mozillazine.org/viewtopic.php?f=42&t=2080949

"... After some playing around, I seem to have fixed the error. Instead of conflicting with a DirectX SDK, it was conflicting with the Windows 6.1 SDK (even though I had set it to use the 7.1 SDK). Renaming the 6.1 directory solved the problem. "
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599634
(Reporter)

Comment 8

7 years ago
I'll be darned. Duping to more appropriate bug 579159.
Duplicate of bug: 579159
Filed Bug 631910 on releasing a new MozillaBuild that contains this fix.
You need to log in before you can comment on or make changes to this bug.