Last Comment Bug 631844 - Should remove event listener for "load" event.
: Should remove event listener for "load" event.
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 7
Assigned To: Hiroyuki Ikezoe (:hiro)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-05 14:14 PST by Hiroyuki Ikezoe (:hiro)
Modified: 2011-08-29 06:08 PDT (History)
4 users (show)
philringnalda: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove the event listener (846 bytes, patch)
2011-02-05 14:15 PST, Hiroyuki Ikezoe (:hiro)
dao+bmo: review+
Details | Diff | Splinter Review

Description Hiroyuki Ikezoe (:hiro) 2011-02-05 14:14:26 PST
From http://tinderbox.mozilla.org/showlog.cgi?tree=Firefox&errorparser=unittest&logfile=1296868329.1296870408.6910.gz&buildtime=1296868329&buildname=Rev3%20MacOSX%20Leopard%2010.5.8%20mozilla-central%20debug%20test%20mochitest-other&fulltext=1


TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/browser_bug581242.js | Current tab should be blank tab
++DOMWINDOW == 215 (0x282a1bf4) [serial = 575] [outer = 0x2829a5a0]
pldhash: for the table at address 0x296e6868, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0x296e6800 == 78
++DOMWINDOW == 216 (0x2871b254) [serial = 576] [outer = 0x0]
++DOMWINDOW == 217 (0x2877d974) [serial = 577] [outer = 0x2871b210]
WARNING: NS_ENSURE_TRUE(sf) failed: file /builds/slave/cen-osx-dbg/build/docshell/base/nsDocShell.cpp, line 4986
WARNING: NS_ENSURE_TRUE(sf) failed: file /builds/slave/cen-osx-dbg/build/docshell/base/nsDocShell.cpp, line 4986
++DOMWINDOW == 218 (0x2879c674) [serial = 578] [outer = 0x2871b210]
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/browser_bug581242.js | about:addons should load into blank tab.
JavaScript strict warning: chrome://mochitests/content/browser/browser/base/content/test/browser_bug581242.js, line 48: reference to undefined property browser.currentURI

Checking browser.currentURI.spec is invoked twice, since "load" event listener is not removed.
Comment 1 Hiroyuki Ikezoe (:hiro) 2011-02-05 14:15:25 PST
Created attachment 510052 [details] [diff] [review]
remove the event listener
Comment 2 Dão Gottwald [:dao] 2011-02-05 16:34:36 PST
(In reply to comment #0)
> Checking browser.currentURI.spec is invoked twice, since "load" event listener
> is not removed.

Why would this happen? That tab gets removed when the first load event is handled, no?
Comment 3 Hiroyuki Ikezoe (:hiro) 2011-02-05 21:04:45 PST
(In reply to comment #2)
> (In reply to comment #0)
> > Checking browser.currentURI.spec is invoked twice, since "load" event listener
> > is not removed.
> 
> Why would this happen? That tab gets removed when the first load event is
> handled, no?

I am not sure the reason but the second load event came from at:

http://hg.mozilla.org/mozilla-central/file/f40e9a9977e2/browser/base/content/tabbrowser.xml#l1638

Is this a bug of tabbrowser.xml?
Comment 4 Phil Ringnalda (:philor, back in August) 2011-06-04 18:26:40 PDT
http://hg.mozilla.org/mozilla-central/rev/57bedceef898
Comment 5 Mihaela Velimiroviciu (:mihaelav) 2011-08-29 06:08:19 PDT
Verified changes were submited to file browser/base/content/test/browser_bug581242.js in mozilla repository.

Is this enough to mark the busg as VERIFIED-FIXED? Or are there any other tests that need to be run to verify this?

Thanks!

Note You need to log in before you can comment on or make changes to this bug.