sidebar splitter visible above new statuspanel

VERIFIED FIXED in Firefox 4.0b12

Status

()

defect
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: mcdavis941.bugs, Assigned: dao)

Tracking

Trunk
Firefox 4.0b12
x86_64
Windows Vista
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Bug 628654 added a statuspanel overlaying page content to show page connecting/waiting/loading state.  If the sidebar is also open and narrow enough that its edge is under the statuspanel, then the sidebar splitter is drawn through the middle of the statuspanel.  

Expected: 
- statuspanel covers sidebar splitter.

Actual:
- sidebar splitter is drawn over/through the statuspanel

Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

This seems like it has to do with z-index on #sidebar-splitter.  Maybe vista/w7-specific.
Component: General → Theme
QA Contact: general → theme
(In reply to comment #0)
> This seems like it has to do with z-index on #sidebar-splitter.  Maybe
> vista/w7-specific.

It would appear you are correct here. I cannot reproduce this under either Linux or Windows/XP.
Duplicate of this bug: 631941
Assignee: nobody → dao
Posted patch patchSplinter Review
Attachment #510260 - Flags: review?(gavin.sharp)
Attachment #510260 - Flags: review?(ehsan)
The z-index was added in bug 426000, why is it unnecessary now?
It's unlikely that it was ever necessary. I suspect it was written this way without trying just position:relative on its own.
Comment on attachment 510260 [details] [diff] [review]
patch

I don't remember why I did that, but it seems unnecessary.  r=me assuming that you've tested under Vista/7.
Attachment #510260 - Flags: review?(ehsan) → review+
Attachment #510260 - Flags: review?(gavin.sharp) → approval2.0?
Attachment #510260 - Flags: approval2.0? → approval2.0+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/18cca558e0ff
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b12
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre

Verified issue and it's no longer present.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.