None of the payment options shows a form to be filled, even if the button is clicked.

RESOLVED DUPLICATE of bug 600077

Status

()

--
major
RESOLVED DUPLICATE of bug 600077
8 years ago
8 years ago

People

(Reporter: vtarasov, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110205 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110205 Firefox/4.0b12pre

None of the payment options shows a form to be filled. The page is unusable
in Firefox. The bug is present in the stable version Firefox/3.6.13 as well.
New profile. Java plugin installed. No other plugins.

Opera-11 and Firefox/2.0.0.22 show the page correctly --
the form for a credit card payment is shown by default.


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.airtran.com and book a flight.
2. Proceed until the payment page https://tickets.airtran.com/Payment.aspx
3. None of the payment options shows a form to be filled, even if the button is clicked.




Might be related to bug 600077
Marked as major because affects a sensitive issue (credit card payment).

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110208 Firefox/4.0b12pre

Using latest build I am unable to reproduce issue.

Can you please try with a clean profile on the latest build?
(Reporter)

Comment 2

8 years ago
The issue is reproduced with a clean (new) profile and the latest build

Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110208 Firefox/4.0b12pre

if "a+ rewards member login" is used at the confirmation page:
https://tickets.airtran.com/Confirm.aspx

If "confirm and continue" is used with the login fields empty,
the issue is present, but in a slightly different form:

There is a form for a credit card payment and the button "use a credit card"
is shown. (This button should be hidden).

The buttons
"use a coupon" (in "discount coupons" section)
"use a gift card" (in "gift cards" section)
"choose an option" (in easy payment options section)
do not work.

(They should close the form for a credit card payment and open their own parts.
The button of the active section is hidden).

The same behaviour occurs on Windows XP2 (both cases).

Comment 3

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre

What I can confirm is that the dropdown buttons for selecting the cities do not open lists in FF (in other browser lists are shown).

https://tickets.airtran.com/Confirm.aspx

Could this be a dupe of bug 631725 ?

Comment 4

8 years ago
Considering that bug 631725 is fixed and current issue is still present, I am marking this bug as a duplicate of bug 600077.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 600077
You need to log in before you can comment on or make changes to this bug.