mozilla frozen when mail window opens

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: gtr, Assigned: bugzilla)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.8 sun4u)
BuildID:    2000121421

mozilla freezes after the mail composer fails to open correctly

Reproducible: Always
Steps to Reproduce:
1. Go to bugzilla's summary-reports page.
2. Get a report on browser for Most-doomed
3. Click on a mail-to link (I clicked on dougt)

Actual Results:
A dialogue box appeared and the app. froze: no respose to any mouse actions in
any windows (mail or browser) but it was still servicing expose events, because
it redrew correctly when I iconified and restored it.

Expected Results:  App. windows remain responsive.

This text appeared on the terminal:

moo!moo!moo!moo!
ComposeLoad from XUL
attempt to UpgradePrefs.  If that fails, open the account wizard.
Compose: ComposeStartup

###ERROR WHILE LOADING MESSAGE COMPOSE: [Exception... "Component returned
failure code: 0x80004005 (NS_ERROR_FAILURE)
[nsIMsgAccountManager.defaultAccount]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://messenger/content/messengercompose/MsgComposeCommands.js ::
ComposeStartup :: line 674"  data: no]
we don't handle eBorderStyle_close yet... please fix me

The error text above appeared on the terminal. The dialogue box
repeated the start of the 2nd paragraph; the dialogue box clipped the text at
the bottom of the box (i.e. was too damn small), and had no scrollbars. I guess
there was an Ok button down in the clipped-off part that it wanted me to push:
hence the app was blocked without being hung in the normal sense of the word.

Comment 1

18 years ago
Reporter, from the error in the console, i'd say you don't have a mail account. 
Apprently Moz will freeze if no account is set up and you manage to reach the 
compose window. So here are the questions :
1) Can you reproduce with a latest build?
2) Do you have a mail account set up for mozilla?
Thanks!
Fabian.
(Reporter)

Comment 2

18 years ago
Correct, I did not have a "mail account" when I found that bug.

With build 2000123121, the behaviour is much better: I get a (modal) dialogue
window inviting me to set up mail, and the debug output on the terminal now reads

ComposeUnload from XUL
JavaScript error:
chrome://messenger/content/messengercompose/MsgComposeCommands.js line 848:
msgCompose has no properties

OnUnload!
Updating wizard map..
Accounttype is mail: undefined
Handle other types () here?
initializing ISP data for mailaccount
AccountWizard.prefillAccountForIsp(mailaccount)
PrefillAccountForISP: filling with null
null account data! clearing..
This is an accountdata
Updating wizard map..
Accounttype is mail: undefined

Please note, however, that the modal dialogue can still get eclipsed by its
parent window if that window gets keyboard focus and jumps to the front. This
gives the effect of the app freezing. One can recover by moving the eclipsing
window, but it's not always obvious what has happened.

Comment 3

18 years ago
Modal dialogs losing focus is another bug, I can find it if you want.
So hmm is the issue you raised considered as fixed? It's not very clear from 
your last comment whether you are happy with the actual behavior (except for the 
modal dialog bug).. if this is not fixed please state them clearly so we can 
update the summary etc :-) Downgrading severity.
Thanks alot,
Fabian. 
Severity: critical → major

Comment 4

18 years ago
resolving worksforme per reporter's comment. please reopen if I'm misreading
comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
Marking verified (wroksforme) based on last comments.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.