Closed Bug 631886 Opened 11 years ago Closed 11 years ago

DirectX not found during configure

Categories

(Firefox Build System :: General, defect)

All
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 630019

People

(Reporter: mozilla, Assigned: mozilla)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13
Build Identifier: 

When compiling Instantbird, but it should be the same with Firefox, I get the following message :
configure: warning: Couldn't find the DirectX SDK, needed for ANGLE. Please install it (February 2010 or newer). To explicitly build without ANGLE, reconfigure with --disable-angle.
configure: warning: This will become an error in the future.

I looked into the configure and found this was due to the line that are looking into the registry for the installation path. The registry value is there and equals to "C:\Program Files\Microsoft DirectX SDK (February 2010)" in my case but when I print the value of the variable that should be assigned with the path in the key, only "DirectX SDK (February 2010)" is displayed.

I tried to modify the line that cause the problem which is line 6361 in the configure.in :
MOZ_DIRECTX_SDK_PATH=`reg query "$MOZ_DIRECTX_SDK_REG_KEY" //v InstallPath | grep REG_SZ | sed 's,  *, ,g' | cut -d' ' -f4-`

If I replace the cut part by "cut -d$'\t' -f3-" it works smoothly. This leads me to think there is differences in how the reg query returns its results depending on the OS because this approach seems to work on the mozilla's build slaves while it is not on Instantbird's (one has only spaces while the other gets tabulations).

I suggest simply to replace tabs by spaces before the sed part, it should get everyone in the same pattern.

Reproducible: Always
This patch replaces tabs by spaces to try to get an uniformed result from the reg query call.
Attachment #510111 - Flags: review?(ted.mielczarek)
Blocks: Instantbird
Assignee: nobody → mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Benoit was doing something with this, I think there might be another bug on this.
(also I would really like to get this all out of configure and just do it in MozillaBuild)
Yeah. You are right about this one. It would be a lot better to do this in MozillaBuild since it already take care of finding the Windows SDK.

But since this would be an improvement and this bug is about fixing an build issue, I think we should consider them separately.
I've recently (bug 630019) landed a change that makes configure.in correctly find the DirectX SDK. From comment 0, it appears that your sources are older than that, and that updating would fix your problem.

It would be fine by me if this was handled in MozillaBuild instead.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630019
Attachment #510111 - Flags: review?(ted.mielczarek)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.