Places queries (aka smart folders, aka smart bookmarks) are not editable after creation

RESOLVED DUPLICATE of bug 475341

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 475341
7 years ago
5 years ago

People

(Reporter: dana, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)

I feel that this has to have been submitted at some point before, but i'm unable to find a bug for it after several search attempts. Apologies in advance if this is a duplicate, but maybe the wording will help someone find it in the future, at the very least....

The issue is as described in the title: Once a Places query has been created in the bookmarks manager, the query is no longer editable. The consequences of this are pretty straight-forward — the main issues for me are that (1) if i make a mistake, i have to delete the bookmark and re-create it, and (2) if i want to go back at a later date and make another query just like it, i have to go out of my way to look up the query syntax on MDC, since it is not something that i use often enough to be able to memorise.

Reproducible: Always

Steps to Reproduce:
1. Launch the bookmarks manager (Bookmarks > Organise Bookmarks or Bookmarks > Show All Bookmarks).

2. Create a new bookmark anywhere you like (right-click > New Bookmark).

3. Enter any name, tags, &c., as you like, then a Places query as the location. For instance, i frequently use queries like: place:terms=%25politics%25&sort=1&queryType=1

4. Click Add.

5. Highlight the newly created bookmark and check the panel at the bottom. Note that there is no 'Location' box like there is for other bookmarks.
Actual Results:  
Unable to edit query.

Expected Results:  
Should be able to edit query.

It appears (judging by how the bottom panel in the Library window looks for each of them) that bookmarks that use Places queries are being treated as folders. This is an OK metaphor, but obviously they are not *precisely* the same thing. It would seem to me to be trivial, and have little or no negative impact on the UI, to add a little 'if places query, show location box' sort of code there.
(Reporter)

Comment 1

7 years ago
I should add that this occurs in Firefox 4b10 as well, sorry.

Updated

7 years ago
Version: unspecified → Trunk
Whiteboard: dupeme

Comment 2

7 years ago
Might be bug 623049.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 475341
You need to log in before you can comment on or make changes to this bug.