Last Comment Bug 631954 - Right-clicking on back button menu item opens additional back button menu
: Right-clicking on back button menu item opens additional back button menu
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All All
-- normal (vote)
: Firefox 6
Assigned To: Dão Gottwald [:dao]
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
: 635631 (view as bug list)
Depends on:
Blocks: 582485
  Show dependency treegraph
 
Reported: 2011-02-06 17:11 PST by Tobias (:Tobbi) Markus
Modified: 2011-06-21 06:48 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1001 bytes, patch)
2011-02-21 10:54 PST, Dão Gottwald [:dao]
gavin.sharp: review+
Details | Diff | Splinter Review

Description User image Tobias (:Tobbi) Markus 2011-02-06 17:11:20 PST
When right-clicking any item in the back button menu, an obsolete back button menu opens at the point that was clicked.

I think this is obsolete and doesn't belong here.

See this screen cast for more details:
http://screencast.com/t/iNgz3VwjQ0Kz
Comment 1 User image Tobias (:Tobbi) Markus 2011-02-06 17:15:03 PST
The issue is that it's registering that click for the underlying back arrow which displays the menu on right-click.

Is this WONTFIX then?
Comment 2 User image (mostly gone) XtC4UaLL [:xtc4uall] 2011-02-07 15:41:01 PST
Confirmed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre ID:20110207030345.
Comment 3 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2011-02-08 00:49:02 PST
Is that a regression from 3.6?
Comment 4 User image Tobias (:Tobbi) Markus 2011-02-08 03:44:35 PST
(In reply to comment #3)
> Is that a regression from 3.6?

Looks like one. When I click on an item in this dropdown in 3.6, no additional menu is opened.
Comment 5 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2011-02-08 05:12:18 PST
Would be great if you could check for the regression range.
Comment 6 User image Tobias (:Tobbi) Markus 2011-02-13 02:07:01 PST
(In reply to comment #5)
> Would be great if you could check for the regression range.

Last good nightly: 2010-10-18 First bad nightly: 2010-10-19

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cfd18201f49b&tochange=c9df0c5cbf8c

From the pushlog it looks like the patch for Bug 582485 caused this.
Comment 7 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2011-02-13 02:10:00 PST
(In reply to comment #6)
> From the pushlog it looks like the patch for Bug 582485 caused this.

Margarete, would that make sense to you?
Comment 8 User image :Margaret Leibovic 2011-02-14 08:25:27 PST
That makes sense, but I can't reproduce this problem on OSX. It seems like the patch in bug 582485 probably exposed some underlying platform-specific issue, since the main thing it did was just take out some "#ifdef XP_MACOSX" lines.
Comment 9 User image (mostly gone) XtC4UaLL [:xtc4uall] 2011-02-20 17:24:05 PST
*** Bug 635631 has been marked as a duplicate of this bug. ***
Comment 10 User image Dão Gottwald [:dao] 2011-02-21 10:54:11 PST
Created attachment 514052 [details] [diff] [review]
patch
Comment 11 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2011-02-25 10:57:52 PST
Comment on attachment 514052 [details] [diff] [review]
patch

I don't understand this patch. Where does this element get a non-empty "context" attribute (it's not defined in the XUL)? Why does "context" on a menupopup have any effect to begin with?
Comment 12 User image Dão Gottwald [:dao] 2011-02-25 11:00:37 PST
#unified-back-forward-button has context="backForwardMenu". The cloned popups don't have a context attribute set without this patch.
Comment 13 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2011-02-25 11:19:56 PST
Seems odd that menupopups inherit "context" from their parents (particularly when they are themselves a context menu...). Shouldn't we fix that?
Comment 14 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2011-02-25 11:24:31 PST
Also, why doesn't this affect other menupopups similarly? Is it because the click-and-hold code opens the popup manually?
Comment 15 User image Dão Gottwald [:dao] 2011-02-25 11:32:48 PST
The cloned popups don't act as context menus. This actually affects other popup menus, like the all-tabs dropdown menu.
Comment 16 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-17 17:27:59 PDT
Comment on attachment 514052 [details] [diff] [review]
patch

I can't seem to reproduce this bug anymore (tried Linux/Mac/Windows). Can someone else confirm?
Comment 17 User image Dão Gottwald [:dao] 2011-05-17 22:45:13 PDT
I can easily reproduce this on Windows.
Comment 18 User image Chris B. 2011-05-18 06:18:16 PDT
(In reply to comment #17)
> I can easily reproduce this on Windows.

I am using the 5/17/11 Nightly and do NOT experience this issue any more, as shown in the original uploaded video from comment 0.  When right-clicking the Back Button, you correctly receive the list of previously opened tabs.  Now, if I right-click on one of those entries, Nightly doesn't generate another list of previous tabs, but instead takes me to that page.  If THIS right-click action to take me to the page listed is in fact a bug (and only the left-click should be enabled here), let me know and I will file it on Bugzilla.
Comment 19 User image Chris B. 2011-05-18 06:29:20 PDT
(In reply to comment #18)
> (In reply to comment #17)
> > I can easily reproduce this on Windows.
> 
> I am using the 5/17/11 Nightly and do NOT experience this issue any more, as
> shown in the original uploaded video from comment 0.  When right-clicking
> the Back Button, you correctly receive the list of previously opened tabs. 
> Now, if I right-click on one of those entries, Nightly doesn't generate
> another list of previous tabs, but instead takes me to that page.  If THIS
> right-click action to take me to the page listed is in fact a bug (and only
> the left-click should be enabled here), let me know and I will file it on
> Bugzilla.

In case it helps.....I am running Windows 7 64-Bit (but the 32-Bit version of Nightly = http://hg.mozilla.org/mozilla-central/rev/f717485edc51).
Comment 20 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-18 15:58:53 PDT
(In reply to comment #18)
> When right-clicking the Back Button, you correctly receive the list of
> previously opened tabs. Now, if I right-click on one of those entries, Nightly
> doesn't generate another list of previous tabs, but instead takes me to that
> page.

I see this too. I even tested all of WinXP/Vista/Win7.
Comment 21 User image Dão Gottwald [:dao] 2011-05-18 23:12:20 PDT
You hold the back button for the menu to appear, then you right-click the menu. I think this bug is just wrongly summarized.
Comment 22 User image Dão Gottwald [:dao] 2011-05-18 23:24:38 PDT
Well, the summary isn't even wrong after all... I just failed to read it properly.
Comment 23 User image Dão Gottwald [:dao] 2011-05-18 23:28:00 PDT
Comment on attachment 514052 [details] [diff] [review]
patch

And I can reproduce this on Linux as well.
Comment 24 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-19 11:31:15 PDT
Comment on attachment 514052 [details] [diff] [review]
patch

add a comment? something like "prevent the context attribute on unified-back-forward-button from being inherited"
Comment 25 User image Dão Gottwald [:dao] 2011-05-20 03:44:47 PDT
http://hg.mozilla.org/mozilla-central/rev/48588658ad9a
Comment 26 User image Simona B [:simonab ] 2011-06-21 06:48:16 PDT
(In reply to comment #23)
> Comment on attachment 514052 [details] [diff] [review] [review]
> patch
> 
> And I can reproduce this on Linux as well.

The behavior described in Comment 18 is still reproducible. Is this ok?

Note You need to log in before you can comment on or make changes to this bug.