Add/Edit Collections tell about errors but fail to say what the error is

VERIFIED FIXED in 5.12.10

Status

P3
critical
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: standard8, Assigned: jbalogh)

Tracking

unspecified
5.12.10

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I'm trying to create an add-on with the following description:

====
Our messaging systems need to evolve - we get more messages, and more kinds of messages than ever. However figuring out how they should change is hard. Luckily, we can try experiments, and gather data. The add-ons included in this collection are all ones that are part of the messaging category on Mozilla Labs: https://mozillalabs.com/messaging/
====

Every time I try to add it, the form tells me: "There are errors in this form. Please correct them below"

It does not indicate which field is at fault, or what the fault might be.

This is also the same on the edit collection form.

From a bit of testing, I believe that there's a length limit on the description field, however the description field is three, maybe four lines in length, so I'm not even overflowing the bounds, and there's no indication of that limit.

I'm using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
(Assignee)

Updated

8 years ago
Assignee: nobody → jbalogh
Priority: -- → P3
Target Milestone: --- → 5.12.10
(Assignee)

Updated

8 years ago
Duplicate of this bug: 633159
(Assignee)

Comment 2

8 years ago
https://github.com/jbalogh/zamboni/commit/a4c8e83
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Created attachment 511875 [details]
Post-fix screenshot
Verified FIXED on https://addons.allizom.org/en-US/firefox/collections/add.
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.