Crash [@ PopActiveVMFrame ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash})

Trunk
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
It is #27 top crasher in Fennec 4.0b4 over the last week.

There are two kinds of stack traces:
Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	PopActiveVMFrame 	js/src/jsinterp.h:281
1 		@0x41ee0eb3 	
2 	libxul.so 	js::mjit::JaegerShot 	js/src/jscntxt.h:2890
3 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:654
4 	libxul.so 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
5 	libxul.so 	JS_CallFunctionValue 	js/src/jsinterp.h:961
6 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2007
7 	libxul.so 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:230
8 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1114
9 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1209
10 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventListenerManager.h:146
11 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:343
12 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:630
13 	libxul.so 	DocumentViewerImpl::LoadComplete 	layout/base/nsDocumentViewer.cpp:1063
14 	libxul.so 	nsDocShell::EndPageLoad 	docshell/base/nsDocShell.cpp:6078
...

Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	PopActiveVMFrame 	js/src/jsinterp.h:281
1 		@0x4329963f 	
2 	libxul.so 	js::mjit::JaegerShot 	js/src/jscntxt.h:2890
3 	libxul.so 	js::Execute 	js/src/jsinterp.cpp:654
4 	libxul.so 	JS_EvaluateUCScriptForPrincipals 	js/src/jsapi.cpp:4933
5 	libxul.so 	JS_EvaluateUCScriptForPrincipalsVersion 	js/src/jsapi.cpp:151
6 	libxul.so 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1552
7 	libxul.so 	nsScriptLoader::EvaluateScript 	nsCOMPtr.h:655
8 	libxul.so 	nsScriptLoader::ProcessRequest 	nsCOMPtr.h:800
9 	libxul.so 	nsScriptLoader::ProcessScriptElement 	content/base/src/nsScriptLoader.cpp:729
10 	libxul.so 	nsScriptElement::MaybeProcessScript 	content/base/src/nsScriptElement.cpp:185
11 	libxul.so 	nsHTMLScriptElement::MaybeProcessScript 	content/html/content/src/nsHTMLScriptElement.cpp:584
12 	libxul.so 	nsHTMLScriptElement::DoneAddingChildren 	content/html/content/src/nsHTMLScriptElement.cpp:511
13 	libxul.so 	nsHtml5TreeOpExecutor::RunScript 	parser/html/nsHtml5TreeOpExecutor.cpp:734
14 	libxul.so 	nsHtml5TreeOpExecutor::RunFlushLoop 	parser/html/nsHtml5TreeOpExecutor.cpp:528
15 	libxul.so 	nsHtml5ExecutorFlusher::Run 	parser/html/nsHtml5StreamParser.cpp:155
16 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
...

It is probably a dupe of bug 615993.

More reports at:
https://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=PopActiveVMFrame
Crash Signature: [@ PopActiveVMFrame ]
(Reporter)

Comment 1

6 years ago
There have been no crashes in Fennec for the last four weeks. It's probably fixed by bug 609244.
I close it as WFM.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.