Last Comment Bug 632056 - Reflect.parse fails to distinguish between FunctionStatement and FunctionDeclaration after constant-folding
: Reflect.parse fails to distinguish between FunctionStatement and FunctionDecl...
Status: RESOLVED FIXED
reflect-parse fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: All All
: -- normal (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 571617
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-07 09:01 PST by Jason Orendorff [:jorendorff]
Modified: 2011-06-27 15:16 PDT (History)
2 users (show)
dherman: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jason Orendorff [:jorendorff] 2011-02-07 09:01:13 PST
Reflect.parse returns the same AST for
  f; if (1) function f(){}
as for
  f; function f(){}
but they are two different programs.
Comment 1 Dave Herman [:dherman] 2011-06-07 00:11:23 PDT
This should go away with the patch for bug 571617.

Dave
Comment 2 Dave Herman [:dherman] 2011-06-23 00:46:20 PDT
Fixed automatically by fix for bug 571617. Landed a test:

http://hg.mozilla.org/tracemonkey/rev/727bc475bb62

Dave
Comment 3 Chris Leary [:cdleary] (not checking bugmail) 2011-06-27 11:42:03 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/727bc475bb62
Note: not marking as fixed because fixed-in-tracemonkey is not present on the whiteboard.

Note You need to log in before you can comment on or make changes to this bug.