when www. is added to URL, the / is parsed out

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: tom.crocker, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

I typed in interlinkexpress.com/callingcard to the address bar and in a "problem loading page" window the following message was returned: Server not found
Firefox can't find the server at www.interlinkexpress.comcallingcard.

Reproducible: Always

Steps to Reproduce:
1.type in interlinkexpress.com/callingcard to the address bar
2.Go!
3.
Actual Results:  
a "problem loading page" window the following message was returned: Server not found
Firefox can't find the server at www.interlinkexpress.comcallingcard.

Expected Results:  
Firefox would add www. to the beginning of the address and the site would load.
I'm almost wondering if there is something in the redirect that is causing this issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
This is most likely a problem dns/server/hosting side. www.domain and domain could even point to different content, even if it's unlikely. it's considered a good choice to have the flat domain return the same content as the www subdomain.
I confirmed this is not a bug.  As you can see below the server is producing an invalid URL on the 302 redirect.

GET /callingcard HTTP/1.1
Host: interlinkexpress.com
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip, deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive

HTTP/1.1 302 Moved Temporarily
Server: hello Grant Grant
Date: Wed, 18 May 2011 13:39:06 GMT
Location: http://www.interlinkexpress.comcallingcard
Content-length: 0
Marking as resolved invalid.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.