If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

openPopup() does not work if another window has the focus

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Michel Gutierrez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

Starting with Firefox 4.0b7, opening a popup panel with openPopup() in the main window has no effect if another window has the focus.

Reproducible: Always

Steps to Reproduce:
1. install the attached extension bugpopup.xpi
2. verify you see a message "Hi, I'm a popup" blinking every second at the bottom right of the window
3. open a window, for instance the Firefox preferences
4. verify the message does not appear anymore
Actual Results:  
The popup only shows if the window holding the popup has the focus or no window Firefox window is focused. In particular, the popup does not show if another Firefox window is focused.

Expected Results:  
The popup should be opened regardless of the focused window, as it was up to Firefox 4.0b6
(Reporter)

Comment 1

7 years ago
Created attachment 510498 [details]
A minimal extension demonstrating the issue

After installing the test case extension, the message "Hi, I'm a popup" should be blinking every second at the bottom right of the main window (unless another Firefox window is focused).
Option/Preferences window is prior when focused. When triggered, Options panel pauses all events in the background until it is closed, including the popup loader script. 

This could be reproducible also on 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.14) Gecko/20110121 Firefox/3.6.14 

and the latest nightly 

Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110206 Firefox/4.0b12pre

but it is not a bug. 
============================================================================
What I've seen though is your addon is making the 3.6.13, 3.6.14 addons manager inaccessible. On popup load, the addons manager closes. The issue is resolved within Firefox 4's new addons manager. 

I'm afraid I have to close this as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.