Door Hanger displays notifications twice

VERIFIED DUPLICATE of bug 616636

Status

()

Toolkit
Add-ons Manager
VERIFIED DUPLICATE of bug 616636
8 years ago
7 years ago

People

(Reporter: Srinivas, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b11])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Chrome/9.0.597.84 Safari/534.13
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre

Door hanger displays notifications twice after cancelling and re-installing addons

Reproducible: Always

Steps to Reproduce:
1.Launch Fx and goto https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/
2.Click "Add to Firefox" - Downloading starts
3.Click "Cancel(X)" in the door hanger - Download Cancels
4.Now again click "Add to Firefox"
5.Now click on the add-on puzzle icon present at the left side in the URL bar 
Actual Results:  
Two notifications are present in the door hanger

Expected Results:  
Only one notification should be displayed
(Reporter)

Updated

8 years ago
Whiteboard: [4b11]
(Reporter)

Comment 1

8 years ago
Created attachment 510550 [details]
Doorhanger

Comment 2

8 years ago
Confirmed
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre ID:20110207030345

This problem does not happen on Linux build.
Blocks: 570012
Status: UNCONFIRMED → NEW
Component: General → Add-ons Manager
Ever confirmed: true
QA Contact: general → add-ons.manager
Version: unspecified → Trunk
Alice, have you performed a regression test to be sure it blocks bug 570012? I would tend to say it's a dupe of bug 616636.

Comment 4

8 years ago
(In reply to comment #3)
> Alice, have you performed a regression test to be sure it blocks bug 570012? I
> would tend to say it's a dupe of bug 616636.

Yes, Landing Bug 570012 causes the problem.
Keywords: regression
This look like just a case of bug 616636, would you agree?
I'm afraid so Dave
Status: NEW → RESOLVED
Last Resolved: 7 years ago
OS: Windows XP → All
Resolution: --- → DUPLICATE
Duplicate of bug: 616636
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.