Absolutely positioned child element in non-static button element has probably incorrect origin

RESOLVED DUPLICATE of bug 437722

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 437722
7 years ago
7 years ago

People

(Reporter: hikingfan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre
Build Identifier: 4.0b12pre (2011-02-07)

A span element within a button that has the following style:

position: absolute;
top: 0px;
left: 0px;

appears in the vertical middle if placed in a button that is non-static.

Reproducible: Always

Steps to Reproduce:
1. Add a button to a page with a span inside
2. Make the button non-static (e.g. position: relative)
3. Make the span positioning absolute, and put it in the origin corner (top: 0px, left: 0px)
Actual Results:  
The span appears in the vertical middle on the left side of the button.

Expected Results:  
The span appears in the top left corner of the button.

Used a test page that overrides all the theme related CSS attributes I can think of. Opera/WebKit based browsers don't reproduce this behavior, IE does.
(Reporter)

Comment 1

7 years ago
Created attachment 510594 [details]
Simple test page that reproduces this bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437722
You need to log in before you can comment on or make changes to this bug.