Editor review emails arriving with no subject

VERIFIED FIXED in 6.0.0

Status

P2
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: jorgev, Assigned: chenba)

Tracking

({regression})

unspecified
6.0.0
regression

Details

(Whiteboard: [post-freeze+][required amo-editors])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
There are at least 2 cases where the review email was sent with no subject at all:

https://addons.mozilla.org/en-US/mobile/addon/near-me-271823/ (review on Jan 30th)
https://addons.mozilla.org/en-US/firefox/addon/TabCloud/ (review on Feb 7th)

We know it doesn't happen for all cases because we have received several recent replies with the correct subject.
Where are the emails?
Priority: P2 → P3
Target Milestone: 5.12.10 → 5.12.11
(In reply to comment #1)
> Where are the emails?

That's kind of vague - I mean, pasting in the emails here would help.  Also, are they all for a specific kind of event?  Or all have localized titles maybe? or have non en-US default locales?
Target Milestone: 5.12.11 → Q1 2011
(Reporter)

Comment 3

8 years ago
What do you need from the emails for? The contents are correct, only the subject is blank.

The first review is Near Me 1.1, reviewed by Kris Maglione, Full Review denied but Granted Preliminary Review.

The second one is TabCloud 0.5, reviewed by Kris Maglione, Full Review denied but Granted Preliminary Review.

Both add-ons have a default en-US locale.
I've just gotten two more of these for https://addons.mozilla.org/en-US/editors/review/129297?num=31 and https://addons.mozilla.org/en-US/editors/review/128739?num=33

I'll note that for the second one, I apparently got logged out after I opened the review page but before I submitted the review and had to submit a second time, but I'm not sure if that's relevant.
I've seen 5 email threads with no subject on amo-editors since last night; we need to look into this sooner.
Priority: P3 → P2
Target Milestone: Q1 2011 → 5.12.12
Assignee: nobody → chenba
Target Milestone: 5.12.12 → 6.0.0
Whiteboard: [required amo-editors] → [post-freeze+]
(Assignee)

Comment 6

8 years ago
It happens when an editor deny a full review on a nominated and preliminary reviewed add-on, setting it back to preliminary review.

The patch adds the missing line.
Attachment #517096 - Flags: review?(clouserw)
Attachment #517096 - Flags: review?(clouserw) → review+
(Assignee)

Comment 7

8 years ago
Committed @ r84108.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Keywords: regression
Whiteboard: [post-freeze+] → [post-freeze+][required amo-editors]

Comment 8

8 years ago
On granting lite review to a nominated add-on, the email notification I received had the subject line- 'bar barsi 4.2 preliminarily reviewed'

marking this verified fixed
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.