Date range on x-axis is correct but the number of plotted points are incorrect

VERIFIED WONTFIX

Status

Input
General
VERIFIED WONTFIX
7 years ago
6 years ago

People

(Reporter: mbrandt, Assigned: davedash)

Tracking

Details

(Reporter)

Description

7 years ago
When filtering on 7 days the date range on the x-axis is correct
however if you count the plotted points on the graph there are 8 of them. 

1) http://input.stage.mozilla.com/en-US/release/
2) click 7d > all > view data

Expected: There should be 7 plotted points on the graph. 
Actual: There are 8 plotted points on the graph.
(Reporter)

Updated

7 years ago
Summary: Date range on x-axis is correct but the number of plotted points → Date range on x-axis is correct but the number of plotted points are incorrect
Wontfixing, because there isn't a great solution here yet...

We are doing 7 days ago which is 2/1/2011 (assuming today is 2/8/2011)), but we are plotting for 2/1, 2/2, ... , 2/8

2/8 is a partial day because it's not done... so really we're showing 7 and change in days.

I thought about lobbing off today - but there's really no reason to lob off current data.

I thought about lobbing off the beginning day, but that causes problems elsewhere.
Assignee: nobody → dd
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Target Milestone: --- → 3.1
Closing as won't fix per general consensus
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.