Add-on Manager tab still listing Add-ons as "Extensions"

VERIFIED WONTFIX

Status

()

Toolkit
Add-ons Manager
VERIFIED WONTFIX
7 years ago
7 years ago

People

(Reporter: MaP, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

It was decided years ago to rename "Extensions" as "Add-ons". The Add-ons Manager in Firefox 4 Beta 11 still shows Extensions.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox 4 Beta 11
2. Go to Tools -> Add-ons in the menu
Actual Results:  
There is a tabbed section on the left that says:
Get Add-ons
Extensions
Appearance
Plugins

Expected Results:  
The list should say:
Get Add-ons
Add-ons
Appearance
Plugins

The term "Extensions" is not used anywhere else in Firefox so its use here is confusing, especially in light of the fact that everything that can be shown there is refered to by add-on authors as "add-ons".
(Reporter)

Comment 1

7 years ago
Created attachment 510806 [details]
Screenshot of the problem.
This is no different in Fx 4 as in other Versions and e.g. Thunderbird.
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Whiteboard: dupeme
I don't recall that decision being made, can you reference it?

What we have long said is that extensions are a type of add-on (along with themes, locales, plugins, etc...) and while we recognise that many users won't really distinguish the difference it still felt right with the redesign to keep the categories as they were.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Whiteboard: dupeme
(Reporter)

Comment 4

7 years ago
I've been searching for the last hour but I am unable to find a reference. It was a long time ago (FF 1.5 or 2.0 time frame?). I remember several news articles saying that extensions would be known as addons going forward. Mozilla even renamed the extensions.mozilla.org website as addons.mozilla.org. Maybe those news articles are lost to the sands of time.
We certainly switched from focusing on extensions since it no longer made sense, Tools - Extensions and Tools - Themes were merged into Tools - Add-ons, extensions.mozilla.org listed extensions and themes.
Also AMO is a place to host all types of add-ons. When you look closely enough it lists extensions, themes, Personas, search engines, and even more. As Dave said, we now have one single entry for the main menu but we have to split up the different kinds of add-ons in the manager.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.