If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"None" should be added to Recent Pages

VERIFIED FIXED

Status

()

Core
Editor
--
enhancement
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Mike Kowalski, Assigned: Matthew Paul Thomas)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
I can't find what component this would go under, but it has to do with 
Composer. Under the File menu I think "None" should be added to Recent Pages if 
there isn't any recent documents.

Comment 1

17 years ago
What happens instead?

Comment 2

17 years ago
over to UIDF.
Assignee: asa → hangas
Status: UNCONFIRMED → NEW
Component: Browser-General → User Interface: Design Feedback
Ever confirmed: true
QA Contact: doronr → mpt
(Reporter)

Comment 3

17 years ago
Nothing happens. It just doesn't show any recent documents, but it doesn't say 
anything.
(Assignee)

Comment 4

17 years ago
Good catch. Selecting the `Recent Pages' item doesn't do nothing; it shows a
little submenu, approx. 4px*4px.

I think the `Recent Pages' submenu should be disabled completely if there are no
recent pages to show, rather than opening to show a `None' item.
(Reporter)

Comment 5

17 years ago
I agree. It should be disabled instead of saying 'None'.
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0

Comment 6

17 years ago
Chaning the qa contact on these bugs to me. MPT will be moving to the 
owner of this component shortly. I would like to thank him for all his hard 
work as he moves roles in mozilla.org...Yada, Yada, Yada...
QA Contact: mpt → zach

Comment 7

17 years ago
updating to new owner. sorry for the spam.
Assignee: hangas → mpt

Comment 8

17 years ago
Shouldn't this be the Editor component? According to the summary: "I can't find
what component this would go under, >>> but it has to do with Composer. <<<
Under the File menu I think "None" should be added to Recent Pages if there
isn't any recent documents."

Changing Product...
Component: User Interface: Design Feedback → Editor
(Reporter)

Comment 9

17 years ago
Instead of adding "None" to the menu, the submenu item should just be disabled.
(Reporter)

Comment 10

17 years ago
Created attachment 28025 [details]
pic showing it disabled in latest build
(Reporter)

Comment 11

17 years ago
Created attachment 28026 [details]
pic showing it disabled in latest build

Comment 12

17 years ago
This works the way we want it to ... Mark Invalid?
(Reporter)

Comment 13

17 years ago
I'm not sure because when I reported it all it showed was a little box next to 
it. It could be a dup of another bug and it was fixed.
(Reporter)

Comment 14

17 years ago
Mark WORKSFORME?
(Reporter)

Comment 15

17 years ago
I'm using Build ID: 2001031915 and it worksforme. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
verified in 3/22 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.