`Mozilla Registry' file should be placed in Application Support folder

VERIFIED INVALID

Status

()

defect
VERIFIED INVALID
19 years ago
11 years ago

People

(Reporter: mpt, Assigned: rayw)

Tracking

Trunk
PowerPC
Mac System 8.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

19 years ago
Build: 2000121514, Mac OS 9.0

To reproduce:
* Install and run Mozilla.
* Find the `Mozilla Registry' file.

Where it is:
* System Folder:Preferences:Mozilla Registry

Where it should be:
* System Folder:Application Support:Mozilla:Component Registry

Comment 1

19 years ago
Arguable.  Preference folder is per user, I assume application support is not.
Presumably different users can have different registered modules.

If all users use sane moz moudles and thus config file should be in application 
support folder, is valid bug, ows. is perhaps invalid.

Answer is - can different users have different moz modules registered?

Comment 2

19 years ago
<p class=iirc>
The theory is that you can indeed have different components installed. However, 
I thought you could have a default moz registry near the app that defines what 
is available to everyone, and then another registry that is per user.
</p>

Comment 3

19 years ago
Yes, good point. Mozilla Registry is the per user file in the preferences folder, 
and Component Registry is the file in the same folder as Mozilla that defines 
which components are installed.

Component Registry should probably stay where it is or move to Essential Files or 
Components to unclutter the top level Mozilla folder.

I see no benefit of moving it to Application Support, it just makes Mozilla 
harder to uninstall (you can't just trash the folder) and makes it harder to have 
multiple mozilla's installed at once. Mozilla Registry should similarly remain in 
Preferences since I think it defines where the Mozilla User Profiles are 
installed for each Mac OS User. (Since multiple mac os users could all have 
multiple different private mozilla profiles).

The only thing I think you'd want to place in Application Support is the 
hypothetical "XPToolkit Registry" if such a file ever came to exist. This would 
share information between multiple XpToolkit apps.

WONTFIX unless Mathew has a counter argument?
Reporter

Comment 4

19 years ago
Ok, if Mozilla Registry is per-user, this is invalid. Thanks for the 
explanations.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
Assignee

Comment 5

18 years ago
The tree may still be red because it missed the checkin, or it could be because
that was not the problem, or it could be because my removal of '&' which is in
this patch, was not applied.
Assignee

Comment 6

18 years ago
Sorry, this comment hit the wrong bug.
verified.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XPCOM Registry → XPCOM
QA Contact: rayw → xpcom
You need to log in before you can comment on or make changes to this bug.