Overflowed tab titles appear above app tabs for 1-2secs (apparently only with DirectWrite disabled)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Felipe, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [hardblocker])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 510873 [details]
Screenshot

See attached screenshot. I'm seeing this bug frequently on my 2 machines. I don't know exactly when it started but my best guess is sometime around the weekend.

I can't really tell yet if this bug is a theme or layout bug. Here's relevant info:

 - I see it happening on trunk often but can't reliably reproduce it. It happens often when I switch tabs and type something in the url bar making the awesomebar appear

 - I just noticed that this computer has HW accel blocked, making directwrite disabled by default. If I enable it, the bug goes away. (I'll verify on my other computer at home if it's the same situation)

 - With the patch for bug 610080, this problem is reproducible 100% of the time

 - With the patch for bug 631698, the problem goes away


The nature of the bug seems very similar to bug 630835, but that bug is filed about CSS transitions, and I don't think we use them in the tab bar (although it's likely that the problem in 630835 is not exclusive of transitions)

Comment 1

8 years ago
>  - I just noticed that this computer has HW accel blocked, making directwrite
> disabled by default. If I enable it, the bug goes away. (I'll verify on my
> other computer at home if it's the same situation)

I experienced this with directwrite enabled (my computer also has Direct2D blocked, but I set gfx.font_rendering.directwrite.enabled to true when testing STR bug 631698).
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?

Comment 2

8 years ago
This happened again with the same configuration, but the text hung around until I moused over it, which caused the app tabs to be repainted correctly (and the text to disappear). This seems to indicate that this is more of a layout bug than a theme bug.
Component: Theme → Layout
Product: Firefox → Core
QA Contact: theme → layout
I wonder if this is related to bug 632923.
(Reporter)

Comment 4

8 years ago
I bisected this on Windows by going through the changesets with hg bisect and applying the patch from 610080 which makes this easier to see.

The bisect pointed to:
http://hg.mozilla.org/mozilla-central/rev/983c98ba560b
Bug 623338 - Block old drivers for ATI & NVIDIA (older than June 2010) - r=joe, a=blocking2.0 

Which didnt't really help beyond telling that indeed it looks like to happen only with HW/DW disabled and it was masked before because my nvidia driver wasn't blocked
You can disable accelerated layers with a pref, search about:config for layers, and it should be obvious what to change.
Felipe, can you try again per comment #6?
(Reporter)

Comment 8

8 years ago
This bug is not visible on trunk anymore since the landing of bug 631698, so I can't tell if it was fixed by bug 632379.
Also, I've been trying to bisect again with Timothy's suggestion but it was unsuccessful because the patch with the CSS changes used to trigger it doesn't apply cleanly depending on how far back in history I go, and fails to trigger the problem too.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.