Deleting message from public folder in exchange IMAP account using Thunderbird

RESOLVED INVALID

Status

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: jp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs protocol log][exchange])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Thunderbird/3.1.7

Thunderbird is unable to delete message from public folder but deleting messages from inbox works fine. Every time I perform a delete operation under Public Folders it prompts me with error message shown below:
ERROR: The current command did not succeed "there is no replica for that mailbox on this server"
Plus deleting message from “Public Folders” doesn’t move the message to “Deleted items” either, so it can be purged (compact) later.
Under Account/Server Settings there are 3 operations I can perform on pressing the delete button on a message:
1.	Move to this Folder: Deleted Items
When I press delete on Public Folder Item it prompts me the error message shown above
2.	Just mark it as deleted
This method tries to mark the Public Folder item as deleted but unsuccessful
3.	Remove it immediately
Under this operation deleted items under Public Folders gets does not get deleted either. The item vanishes from the folder but as you go back in the same folder it pops back in.


Reproducible: Always

Steps to Reproduce:
1. login into your IMAP SSL exchange account
2. Go to any of your public Folder
3. Press delete button or Move the item to Junk Folder
Actual Results:  
Error: The current command did not succeed "there is no replica for that mailbox on this server

Expected Results:  
item to be deleted from public folder permanently

I am able to delete items when using IMAP exchange account in outlook but not able to do in Thunderbird
Can we get a nice imap log as described at https://wiki.mozilla.org/MailNews:Logging ?
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Problem itself seems known issue with Exchange server.

Google search result for 'exchange imap "there is no replica for that mailbox on this server"'.
> http://www.google.com/search?hl=en&biw=1134&bih=569&q=exchange+imap+"there+is+no+replica+for+that+mailbox+on+this+server"&aq=f&aqi=&aql=&oq=
Many web pages are listed by the Google search. Many peoples seem to have suffered/are still suffering from the error.

First top 3 hits.

> (1) http://support.microsoft.com/kb/217388

> (2) http://www.google.com/support/forum/p/Google%20Apps/thread?tid=4f8dc38d76adc7f8&hl=en

> (3) http://mckenzie-electronics.com/documentation/thunderbird.html
> Copying from Exchange User Mailboxes to Public Folders
> If you try to drag a mailbox item from your mailbox to a Public Folder then
> you will receive the message: "There is no replica for that mailbox on this server."
> This is a quirk of Exchange's IMAP4 support. Two work arounds are as follows:
>  1. Move the Exchange Mailbox item to a Local Folder, then move the item back to the Exchange Public Folder
>  2. If the Public Folder has been e-mail enabled, forward the Mailbox item to the Public Folder Email address.

I can't think Exchange's bug. I can't believe Tb's bug also.
I guess server side setup problem, by casual server management peoples, without sufficient knowledge about Exchange server, without detailed knowledge about IMAP and IMAP related RFCs, although I can never say "there is no bug of Tb around Public Folder support" because the message seems "there is no such mailbox"("Tb requested wrong mbox name" is suspected.)

Because here is B.M.O, not support forum, attach IMAP log file as Ludovic requets, please.
Before open log to public, remove/replace sensitive data from log file, please.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Whiteboard: [needs protocol log][exchange]
You need to log in before you can comment on or make changes to this bug.