when hidden, bookmarks menu button shouldn't appear when customizing toolbars

RESOLVED DUPLICATE of bug 581238

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 581238
7 years ago
7 years ago

People

(Reporter: fryn, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Reporter)

Description

7 years ago
By default on Windows XP, we show the traditional menu bar. Because of this, we hide the bookmarks menu button. However, when opening the toolbar customization panel, the bookmarks menu button appears in the toolbar (then disappears upon panel closure)! This shouldn't happen.
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Non-primary UI, non-default settings - this does not sound severe enough to block the release.
blocking2.0: ? → -
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Non-primary UI, non-default settings - this does not sound severe enough to
> block the release.

As I explained above, the bug appears with the default settings. Start Firefox on XP, open customization panel, and there it is. Even so, this might not be enough to block.
Ok. What's the actual effect of it showing that is the reason to block?
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> Ok. What's the actual effect of it showing that is the reason to block?

It is confusing, bogus UI. A user starts Firefox 4 on XP for the first time with all default settings. The user wants to tweak the toolbars and opens the customization panel. The bookmarks menu button appears in the toolbar. The user is surprised and perhaps expects that the bookmarks menu button will remain there after the panel closes, but instead it disappears.

We may frustrate users by giving them something when they didn't expect or necessarily want it and then by taking it away without any obvious method of getting it back after the user perhaps realizes that he/she wants it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581238
You need to log in before you can comment on or make changes to this bug.