Closed Bug 632730 Opened 12 years ago Closed 12 years ago

Opening new tab with CMD-T when focus is on tab with flash player crashes flash plugin

Categories

(Core Graveyard :: Plug-ins, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 634387

People

(Reporter: kaustubh.gadkari, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

After opening a new tab with CMD-T when the focus is on a tab using the flash plugin, the flash plugin crashes. This does not seem to happen when a new tab is opened using the new tab button.

Reproducible: Always

Steps to Reproduce:
1. Open a new tab.
2. Start a youtube video in this tab.
3. Open a new tab using CMD-T.
Actual Results:  
The flash plugin will crash.

Expected Results:  
The video should continue playing.

I am using flash v10.1.102.64. Using flash v10.2 degrades performance (flash videos drop frames).
This seems to have been fixed in the latest nightly.
The nightly doesn't fix this issue. What I've found is that this issue happens when Firefox is opened in 32-bit mode, regardless of the version. I'm using Flash 10.2 and I've tested this on 4.0b11, and the 4.0pre12 nightly, run in 64 and 32 bit mode.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 634387
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.