mail pane switching with "tab" and "shift-tab" is slow, especially when mail folder has lots of elements

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P2
normal
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

({perf})

Trunk
Future
x86
All

Firefox Tracking Flags

(Not tracked)

Details

while testing blake's fix for #69204, I noticed this.

it should not be as slow as it is.

as blake pointed out, just clicking between panes is slow, too.
updating summary.

I'm sure this is related to other performance problems we have.

accepting.
Status: NEW → ASSIGNED
Keywords: perf
Summary: pane switching "tab" and "shift-tab" is slow, especially when folder has lots of elements → pane switching with "tab" and "shift-tab" is slow, especially when folder has lots of elements

Comment 2

17 years ago
If Netscape is hiring, I'm available, if they can pay me. I can and will crunch
this sucker 15%-35% and make it real fast! But not for free!

Most friendly, HJ.
Dude, what are you smoking? Settle down a little! :-)

Comment 4

17 years ago
See bliz's post in n.p.m.performance:

"I've noticed that performance problems seem to be back when switching 
between frames in mail/news again.  For example on my PII 400 on the 
laptop it takes a full 2 seconds to switch focus from the mail message 
pane to the folder list pane.  Are people aware of this?

--Chris"
adding blizzard to the cc list so he knows we are working on it.

Comment 6

17 years ago
Well, the consensus in the thread seems to be that it's due to the enabling of 
style context sharing and other things that are out of mail's control.

Updated

17 years ago
QA Contact: esther → nbaca

Comment 7

17 years ago
nominating to get on radar
Keywords: mail1

Comment 8

17 years ago
we should look into this. marking nsbeta1+ and moving to mozilla0.8 
Keywords: nsbeta1
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.8
I'm not seeing this anymore.  bliz, are you seeing it?

did the cause of it get fixed?

cc'ing attinasi.
I think that the extreme slowness that this bug was opened against got fixed.
However, I think that on this PII 400 that switching panes is still really,
really slow.  It takes ~1.5 seconds here which is still a long time for a UI to
respond to a simple focus change.

Comment 11

17 years ago
This probably speeded up when I turned on the FastCache (tm) in the style
system. I think general style resolution sped up by like 10 times in the
thread-pane ( information from anecdotal sources only, not a scientific survey).

If it still seems too slow, you can turn off style sharing and see if it is any
faster: set the env. var. moz_disable_style_sharing=1 and restart Moz - if it
isconsiderably slower with sharing on then please let me know.
The last time I checked there wasn't a big speed difference between no style
sharing and using the style cache.  That's isn't what I'm complaining about.
I'm just saying that even with that speed increase, it's still to slow on many
reasonably powered machines.  Focus switching in the mail pane is probably one
of the best examples of performance problems that I can think of.

Comment 13

17 years ago
I getcha - I didn't mean to sound defensive, really ;) There are a couple of
more optimizations I need to make to help speed up style resolution in general,
which apparently is the bottleneck for tree controls. They are covered in bug
53620, bug 53796 and bug 62895. Hopefully when these are addressed it will help
speed up the mailnews client a bit. However, there may be other performance
problems that are making focus shifting slow: I am only aware of the style
resolution issues.
perf, she's all mine, baby!
QA Contact: nbaca → stephend

Comment 15

17 years ago
moving to mozilla0.9
Target Milestone: mozilla0.8 → mozilla0.9
*** Bug 69353 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
marking nsbeta1- and moving to future milestone.
Keywords: nsbeta1 → nsbeta1-
Whiteboard: [nsbeta1+] → [nsbeta1+ 2/21]
Target Milestone: mozilla0.9 → Future

Comment 18

17 years ago
This is still a significant problem for me on the latest nightly builds.  If I
create a new message and try to tab or click between the "To", "Subject", or
"Message body" fields in the mail composer, the delay is unbearable.  Perhaps up
to 2 seconds sometime, just to tab!  This makes using the mailer awful clunky.

I hope someone is still working on this.  I doubt you will get many mail
converts otherwise.  Let alone, it really annoys me.  :^)
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW

Comment 19

12 years ago
WFM - win XP, all is instantaneous
what about linux?

Comment 20

12 years ago
I see that this Bug is from 2000 and was resolved in Mozilla, as I never had problems on switching tabs un my 500Mhz-machine (I'm able to go trough more than 5 tabs in a second, even with >20 tabs)
But in SEAMONKEY 1.0 the problem reappears: tab switching needs >1 sec!!

Its the only problem i've encountered switching to seamonkey, all the other changes are damn good and useful! Thank you all!

Comment 21

12 years ago
(In reply to comment #20)
...I forgot my system's specs: Seamonkey 1.0 on Win98SE on an Athlon 550MHz. 

> I see that this Bug is from 2000 and was resolved in Mozilla, as I never had
> problems on switching tabs un my 500Mhz-machine (I'm able to go trough more
> than 5 tabs in a second, even with >20 tabs)
> But in SEAMONKEY 1.0 the problem reappears: tab switching needs >1 sec!!
> 
> Its the only problem i've encountered switching to seamonkey, all the other
> changes are damn good and useful! Thank you all!
> 

Comment 22

11 years ago
WFM.

Please reopen if you still see this can can cite a specific set of steps to be tested.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Summary: pane switching with "tab" and "shift-tab" is slow, especially when folder has lots of elements → mail pane switching with "tab" and "shift-tab" is slow, especially when mail folder has lots of elements
Whiteboard: [nsbeta1+ 2/21]
You need to log in before you can comment on or make changes to this bug.