In some websites the "Back" button does not work

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: t8av, Unassigned)

Tracking

3.6 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.13) Gecko/20101203 BTRS28059 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.13) Gecko/20101203 BTRS28059 Firefox/3.6.13

In some websites, you cannot use the "Back" navigation button of Firefox.

Example for such a website:

http://www.associatedcontent.com/article/566147/top_5_cheapest_countries_in_the_world.html?cat=3

Reproducible: Always

Steps to Reproduce:
1. Go to any website, such as the homepage.

2. Go to a website such as http://www.associatedcontent.com/article/566147/top_5_cheapest_countries_in_the_world.html?cat=3

3. Click the "Back" (Left arrow" button of firefox, or menu History->Back
Actual Results:  
The browser stays at the same website

Expected Results:  
The browser should go to the previous website.

I guess this is caused by some javascript code at the website, however firefox should protect the user from such cases and make the "Back" button usable.

Comment 1

7 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110121 Firefox/3.6.14

Works fine for me. Able to click the back button. Please try if it works fine in safe mode or try by creating a new profile. 
https://support.mozilla.com/en-US/kb/Safe+Mode
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.14) Gecko/20110121
> Firefox/3.6.14
> 
> Works fine for me. Able to click the back button. Please try if it works fine
> in safe mode or try by creating a new profile. 
> https://support.mozilla.com/en-US/kb/Safe+Mode
> https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.

It works fine to me now. I can't explain why it did not work yesterday. Please close this bug for me. Thanks.

I will reopen the bug whenever I meet another website which does not allow the "back" button to work (there are quite a few of these, but can't remember any at the moment).

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 3

7 years ago
Closing at reporter's request.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.