Crash [@ nsStyledElement::GetStyle(unsigned int*) ][@ nsStyledElement::GetStyle ]

RESOLVED WORKSFORME

Status

()

Core
DOM
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
All
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
It is a new crash signature in the trunk.
It is #44 top crasher in 4.0b11.

Two comments say:
"Developing an ASP.NET webapp in VS2010, using the Web Developer toolbar to View CSS Information."
"Refreshed when a song was being played on grooveshark."

Signature	nsStyledElement::GetStyle(unsigned int*)
UUID	c9104067-0f48-4a0d-990e-847db2110209
Time 	2011-02-09 03:57:50.586652
Uptime	2387
Last Crash	1642168 seconds (2.7 weeks) before submission
Install Age	2387 seconds (39.8 minutes) since version was first installed.
Product	Firefox
Version	4.0b11
Build ID	20110203141415
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 14 stepping 8
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x8
User Comments	
App Notes 	AdapterVendorID: 1106, AdapterDeviceID: 3371, AdapterDriverVersion: 7.14.14.80

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsStyledElement::GetStyle 	content/base/src/nsStyledElement.cpp:250
1 	xul.dll 	nsGenericHTMLElementTearoff::GetStyle 	content/html/content/src/nsGenericHTMLElement.cpp:255
2 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
3 	xul.dll 	XPC_WN_GetterSetter 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1643
4 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:704
5 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:862
6 	mozjs.dll 	js::ExternalGetOrSet 	js/src/jsinterp.cpp:902
7 	mozjs.dll 	js::JSProxyHandler::get 	js/src/jsproxy.cpp:131
8 	xul.dll 	xpc::XrayWrapper<JSCrossCompartmentWrapper>::get 	js/src/xpconnect/wrappers/XrayWrapper.cpp:765
9 	mozjs.dll 	js::JSProxy::get 	js/src/jsproxy.cpp:780
10 	mozjs.dll 	js::proxy_GetProperty 	js/src/jsproxy.cpp:897
11 	mozjs.dll 	JSObject::getProperty 	js/src/jsobj.h:1198
12 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4203
13 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:661
14 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
15 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:2188
16 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4784
17 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:661
18 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
19 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:862
20 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5053
21 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2008
22 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:9105
23 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9450
24 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
25 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
26 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
27 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
28 	xul.dll 	xul.dll@0xb27a57 	
29 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
30 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
31 	mozcrt19.dll 	_VEC_memzero 	
32 	xul.dll 	xul.dll@0x357c5d 	
33 	firefox.exe 	firefox.exe@0x1bb7 	
34 	ntdll.dll 	ntdll.dll@0x1d554 	
35 	ntdll.dll 	ntdll.dll@0x5b3fb 	
36 	firefox.exe 	firefox.exe@0x186f 	
37 	firefox.exe 	firefox.exe@0x186f 

More reports at:
https://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=nsStyledElement%3A%3AGetStyle%28unsigned%20int*%29
(Reporter)

Comment 1

8 years ago
It is #6 top crasher on Mac OS X in 4.0b12pre over the last week.
OS: Windows 7 → All
Summary: Crash [@ nsStyledElement::GetStyle(unsigned int*) ] → Crash [@ nsStyledElement::GetStyle(unsigned int*) ][@ nsStyledElement::GetStyle ]
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsStyledElement::GetStyle(unsigned int*) ] [@ nsStyledElement::GetStyle ]

Comment 2

7 years ago
All crashes over the past month with this signature appear on 4.0. Resolving as works for me.
Status: NEW → RESOLVED
Crash Signature: [@ nsStyledElement::GetStyle(unsigned int*) ] [@ nsStyledElement::GetStyle ] → [@ nsStyledElement::GetStyle(unsigned int*) ] [@ nsStyledElement::GetStyle ]
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.