Closed Bug 632869 Opened 9 years ago Closed 6 years ago

radioparadise.com: "Now playing" list not working due to HTML5-incompliant innerHTML expectations

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: hsivonen, Unassigned)

References

()

Details

At the top of the page at http://www.radioparadise.com/, the "Now Playing" list doesn't populate in Firefox 4, reportedly (in bug 395597 comment 14) due to HTML5-compliant innerHTML behavior.
Duplicate of this bug: 632870
Here's a better example than the one i posted in Bug 395597 : 

http://www.oele.net/innerhtmljs2.html

The script executes in IE9, Chrome 8, Opera 11 and FF3.6, but not in FF4.
The script that does this on the radioparadise.com site is the current version of the "Cross Browser Ajax" library (http://crossbrowserajax.com/). I will notify them of this problem too.
It looks like RadioParadise.com may have fixed this by switching to jquery for their ajax calls.

So is the Cross Browser Ajax library in need of an update? Or will there be a bug fix in FF4 for this?  I'm using a zen-cart addon called Advanced Shipper and it's configuration makes use of v1.1 of the cross browser ajax library mentioned above. It makes use of cba.js to make a simply request to retrieve a small amount of data, but the callback function never gets called in FF4.  Works in FF3.6 and other browsers though.
(In reply to comment #4)
> So is the Cross Browser Ajax library in need of an update?

Probably.

> Or will there be a bug fix in FF4 for this?

This isn't a bug in the browser, so no.
This is working
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.