Touchpad/mouse scrolling error with (Adobe Reader) PDF in background tab

RESOLVED DUPLICATE of bug 626813

Status

()

Core
General
RESOLVED DUPLICATE of bug 626813
7 years ago
2 years ago

People

(Reporter: menuet, Unassigned)

Tracking

({regression})

2.0 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

When I have a PDF open using adobe reader in one tab and then switch focus to another tab, attempting to scroll using the trackpoint on my laptop causes the PDF to scroll (even though it's not even visible) rather than the tab with focus.

Reproducible: Always

Steps to Reproduce:
1. Open a PDF using adobe reader
2. Switch to a different tab
3. Try to scroll in the tab with focus - the PDF will scroll instead.
Actual Results:  
The page with focus didn't scroll, but the PDF without focus did.

Expected Results:  
The page with focus should have scrolled, the PDF should not have.

Comment 1

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre

Works fine for me. Please try if it works fine in safe mode or try by creating a new profile. 
https://support.mozilla.com/en-US/kb/Safe+Mode
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.

Comment 2

7 years ago
Works for me using Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11.

Menuet, what version of Adobe Reader are you using?
(Reporter)

Comment 3

7 years ago
I am using the most recent version of Adobe Reader (10.0.1) - I updated to make sure it was still giving problems.

For the record, the driver I'm using is a Synaptics Touchpad driver (6.2) for an HP Compaq tc4400 laptop. This driver shouldn't be more than a couple months old, if it's not the most recent. It works fine in all other applications.

Everything seems to work fine in safe mode. I also noted that the cursor changes to a little scroll icon when the bug happens (firefox usually doesn't do this, but adobe does). If I run it in safe mode and everything works properly, the scroll icon doesn't change.

Long story short, not a problem in safe mode.

Comment 4

7 years ago
I have the exact same problem (using Adobe Acrobat 9.1.0.163 Plugin)
Samsung R580, also Synaptics touchpad
It worked fine in V3.6, I noticed it as soon as I upgraded to version 4.0

Updated

7 years ago
Duplicate of this bug: 648713

Updated

7 years ago
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
Keywords: regressionwindow-wanted
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 2.0 Branch
Duplicate of this bug: 648931
Can one of you who is experiencing this issue check our beta releases of Firefox 4? It would be a good start to know which of those first introduced this issue. Those builds can be found at:

http://stage.mozilla.org/pub/mozilla.org/firefox/releases/
Keywords: regression

Updated

7 years ago
Summary: Trackpoint scrolling error with PDF in background tab → Touchpad/mouse scrolling error with (Adobe Reader) PDF in background tab

Comment 8

7 years ago
dupe of Bug 315513 or Bug 627275 ?
Duplicate of this bug: 652347
menuet, do you also see this issue in Firefox 3.6.x?

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 273456

Comment 12

7 years ago
This is not a duplicate of bug 273456. This is a new issue in Firefox 4.0 where touchpad scrolling will not work (except for pdfs) unless all tabs containing a pdf are closed. The older bug could be worked around without closing the pdf.

Bug 638671, Bug 626813, and Bug 641299 appear to all be duplicates of this bug.

This, along with some other minor problems I have with FF4 make me want to either downgrade or switch browsers completely.

Updated

7 years ago
Duplicate of bug: 626813
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.