Closed Bug 632908 Opened 9 years ago Closed 9 years ago

Java errors and crash on startup with Android 2.1

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: azakai, Assigned: blassey)

References

Details

Attachments

(1 file)

logcat:


V/InputDevice( 2264): ID[0]=0 Dn (0=>1)
I/PowerManagerService( 2264): ULight 3->7 f0
V/WindowManager( 2264): Dsptch > Window{47bdf2f0 com.sec.android.app.twlauncher/com.sec.android.app.twlauncher.Launcher paused=false}
V/InputDevice( 2264): ID[0]=0 Up (1=>0)
V/WindowManager( 2264): Dsptch > Window{47bdf2f0 com.sec.android.app.twlauncher/com.sec.android.app.twlauncher.Launcher paused=false}
I/ActivityManager( 2264): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.fennec/.App }
D/Launcher( 2349): launcher is paused
I/ActivityManager( 2264): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=3010 uid=10089 gids={3003, 1015}
I/Zygote  ( 3010): Zygote: pid 3010 has INTERNET permission, then set capability for CAP_NET_RAW(13)
W/Resources( 2264): Converting to boolean: TypedValue{t=0x3/d=0x16fb "res/anim/accelerate_decelerate_interpolator.xml" a=1 r=0x10a0004}
W/Resources( 2264): Converting to boolean: TypedValue{t=0x3/d=0x16fb "res/anim/accelerate_decelerate_interpolator.xml" a=1 r=0x10a0004}
D/dalvikvm( 3010): DexOpt: couldn't find static field
W/dalvikvm( 3010): VFY: unable to resolve static field 22 (DIRECTORY_DOWNLOADS) in Landroid/os/Environment;
D/dalvikvm( 3010): VFY: replacing opcode 0x62 at 0x0013
D/dalvikvm( 3010): Making a copy of Lorg/mozilla/gecko/GeckoApp;.checkAndLaunchUpdate code (573 bytes)
I/GeckoApp( 3010): create
I/GeckoAppJava( 3010): Checking for an update
I/dalvikvm( 3010): Could not find method android.util.Base64.decode, referenced from method org.mozilla.gecko.GeckoAppShell.installWebApplication
W/dalvikvm( 3010): VFY: unable to resolve static method 125: Landroid/util/Base64;.decode (Ljava/lang/String;I)[B
D/dalvikvm( 3010): VFY: replacing opcode 0x71 at 0x007b
D/dalvikvm( 3010): Making a copy of Lorg/mozilla/gecko/GeckoAppShell;.installWebApplication code (312 bytes)
I/dalvikvm( 3010): Could not find method org.mozilla.gecko.GeckoApp.getExternalFilesDir, referenced from method org.mozilla.gecko.GeckoAppShell.loadGeckoLibs
W/dalvikvm( 3010): VFY: unable to resolve virtual method 417: Lorg/mozilla/gecko/GeckoApp;.getExternalFilesDir (Ljava/lang/String;)Ljava/io/File;
D/dalvikvm( 3010): VFY: replacing opcode 0x6e at 0x0054
D/dalvikvm( 3010): Making a copy of Lorg/mozilla/gecko/GeckoAppShell;.loadGeckoLibs code (1245 bytes)
I/dalvikvm( 3010): Could not find method org.mozilla.gecko.GeckoApp.getExternalFilesDir, referenced from method org.mozilla.gecko.GeckoAppShell.loadGeckoLibs
W/dalvikvm( 3010): VFY: unable to resolve virtual method 417: Lorg/mozilla/gecko/GeckoApp;.getExternalFilesDir (Ljava/lang/String;)Ljava/io/File;
D/dalvikvm( 3010): VFY: replacing opcode 0x6e at 0x0103
D/dalvikvm( 3010): GC freed 2143 objects / 160736 bytes in 32ms
D/dalvikvm( 3010): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47b36bb0
D/dalvikvm( 3010): Added shared lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47b36bb0
D/dalvikvm( 3010): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozutils.so 0x47b36bb0
W/dalvikvm( 3010): threadid=19: thread exiting with uncaught exception (group=0x4001dc20)
E/AndroidRuntime( 3010): Uncaught handler: thread Thread-9 exiting due to uncaught exception
I/GeckoApp( 3010): start
I/GeckoApp( 3010): resume
E/AndroidRuntime( 3010): java.lang.NoSuchMethodError: org.mozilla.gecko.GeckoApp.getExternalFilesDir
E/AndroidRuntime( 3010): 	at org.mozilla.gecko.GeckoAppShell.loadGeckoLibs(GeckoAppShell.java:207)
E/AndroidRuntime( 3010): 	at org.mozilla.gecko.GeckoApp$3.run(GeckoApp.java:204)
E/AndroidRuntime( 3010): 	at java.lang.Thread.run(Thread.java:1096)
I/Process ( 2264): Sending signal. PID: 3010 SIG: 3
I/dalvikvm( 3010): threadid=7: reacting to signal 3
I/ANDROID_DEBUG( 2264): dumpmesg > /data/log/dumpstate_app.log
I/dalvikvm( 3010): Wrote stack trace to '/data/anr/traces.txt'
I/dumpstate( 3021): begin
I/GeckoAppJava( 3010): surface created
D/dalvikvm( 3010): GC freed 627 objects / 36664 bytes in 28ms
D/dalvikvm( 3010): GC freed 29 objects / 1080 bytes in 27ms
I/GeckoAppJava( 3010): surfaceChanged: fmt: -1 dim: 480 762
W/PowerManagerService( 2264): Timer 0x7->0x3|0x1
I/PowerManagerService( 2264): ULight 7->3 f0
I/dumpstate( 3021): done
I/ActivityManager( 2264): Displayed activity org.mozilla.fennec/.App: 7699 ms (total 7699 ms)
Attached patch patchSplinter Review
alon reports this fixes the issue for him. Also, since eclair doesn't support moving the app to the sd card natively, there's no loss of functionality here
Assignee: nobody → blassey.bugs
Attachment #511106 - Flags: review?(doug.turner)
Blocks: 615519
Attachment #511106 - Flags: review?(doug.turner) → review+
pushed http://hg.mozilla.org/mozilla-central/rev/5fbd37417b22
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 632384
Mozilla /5.0 (Android;Linux armv7l;rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre Fennec /4.0b5pre 

This is not happening anymore.
Marking the bug as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.