[Mozmill] General tests update

RESOLVED FIXED in 1.0b4

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: merike, Assigned: merike)

Tracking

Trunk
1.0b4

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

8 years ago
Created attachment 511112 [details] [diff] [review]
Tests update

Sorry for the patch length, I realized too late that I should've broken it into two after having fixed test breaking issues. It isn't as scary as it might seem though, there are many repetitive changes in there :).

General changes:
* shared modules imports updated
* modal dialog api calls updated
* deprecated api: menu clicks and assertProperty updated
* some clicks converted to select(), radio(), back() and next() where applicable
* waitForEval calls replaced with waitFor
* shared module functions didn't always have controller as an argument, this doesn't work any more
* controller is always first argument in shared module functions for consistency
* sleeps reduced from 199 to 50, removing easy ones
* click coordinates specified for doubleclicks that create events, else mozmill clicks on halfhour, this has changed at some point in mozmill, it used to click top left when coordinates weren't specified

Test specific changes:
* last timezone test now resets timezone prefs afterwards
* switchAppTimezone doesn't have second parameter so not passing one
* adding attendee is now figured out so testEventDialog actually adds and verifies one
* alarm-defaultvalue
 - not language dependent any more
 - sunbird support removed as no other test supports it and Fallen agreed
 - typing values to prefs just appended them, ctrl+a solves it on linux at least, what about mac though?
 - labels refer to correct labels
 - preferences set are now reset afterwards
* testEventDialogModificationPrompt
 - it was trying to select menu separator as a reminder, thus index changed
 - creates multiple instances of modal dialog api, for some reason starting the same instance multiple times didn't trigger handle function properly, need to look into if this can be reproduced elsewhere, according to whimboo this shouldn't happen
* recursion tests
 - in rotated view tests didn't check at all if they were operating in the right view i.e if rotation actually works, added checks
 - they also didn't check if events were deleted successfully, I'd argue they should though it's somewhat questionable if all of them should fail while unrelated feature like deletion is broken

Question:
There are lot of waits for event dialog open and close, these seem like good candidates for addition to shared module?

Important note:
Many tests fail also after changes because deleting by key doesn't work reliably at the moment. So failures after these keypress calls are expected.
Assignee: nobody → gasell+mozilla
Status: NEW → ASSIGNED
Attachment #511112 - Flags: review?(ctalbert)

Comment 2

8 years ago
Comment on attachment 511112 [details] [diff] [review]
Tests update

Wow, that's quite the patch!

Sorry it took so long to get through it. 

It looks great, overall.    

As far as putting the opening of the event dialog into a shared module, I think it would make the code look neater and it might make it easier for people new to writing these tests to be effective.  I don't think it's worth being it's own shared module, maybe just something else in calUtils.  

So, I'd be for it, but I'll leave it up to you to decide whether you want to undertake that refactoring.

r+
Thanks for the patch!
Attachment #511112 - Flags: review?(ctalbert) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/ca34c847dc7d>
-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.