Last Comment Bug 632915 - Mozilla does not compile anymore on arm-hardfp
: Mozilla does not compile anymore on arm-hardfp
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: ARM MeeGo
: -- normal (vote)
: ---
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
: 616413 (view as bug list)
Depends on: 626035
Blocks: 632162
  Show dependency treegraph
 
Reported: 2011-02-09 11:27 PST by Oleg Romashin (:romaxa)
Modified: 2011-12-22 02:46 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
no hardcoded softfp flag (5.33 KB, patch)
2011-02-09 11:31 PST, Oleg Romashin (:romaxa)
no flags Details | Diff | Review
Detect HRDFP in configure and disable softfp only in that case (6.40 KB, patch)
2011-04-17 09:43 PDT, Oleg Romashin (:romaxa)
mh+mozilla: review-
Details | Diff | Review

Description Oleg Romashin (:romaxa) 2011-02-09 11:27:38 PST
Bug 632162 has been landed even with separate ARM_VFP define MOZ_ARM_VFP_FLAGS, but even with that we still have -mfloat-abi=softfp hardcoded
http://hg.mozilla.org/mozilla-central/annotate/280e978fc6fb//configure.in#l7225

CFLAGS="$CFLAGS -march=armv7-a -marm -mfloat-abi=softfp $MOZ_ARM_VFP_FLAGS"

I'm using hardfp toolchain arm.
sbox-arm-none-linux-gnueabi-g++ ('cs2009q3-hard-67-sb12') 4.4.1
Comment 1 Mike Hommey [:glandium] 2011-02-09 11:31:29 PST
This should IMHO be handled with bug 626035
Comment 2 Oleg Romashin (:romaxa) 2011-02-09 11:31:32 PST
Created attachment 511109 [details] [diff] [review]
no hardcoded softfp flag
Comment 3 Oleg Romashin (:romaxa) 2011-02-09 12:03:32 PST
hmm I tried second patch in that bug and got another error:

checking for valid optimization flags... no
configure: error: These compiler flags are invalid: -Os -freorder-blocks -fomit-frame-pointer
Comment 4 Oleg Romashin (:romaxa) 2011-02-09 12:05:55 PST
"alternative proposal" also  does not help with this problem (it does not solve that at all)
Comment 5 Mike Hommey [:glandium] 2011-02-09 12:18:08 PST
(In reply to comment #4)
> "alternative proposal" also  does not help with this problem (it does not solve
> that at all)

no, but the problem is that fiddling with build flags should be done in .mozconfig, not configure.in.
Comment 6 Oleg Romashin (:romaxa) 2011-02-21 20:09:44 PST
*** Bug 616413 has been marked as a duplicate of this bug. ***
Comment 7 Oleg Romashin (:romaxa) 2011-03-30 22:35:51 PDT

*** This bug has been marked as a duplicate of bug 626035 ***
Comment 8 Oleg Romashin (:romaxa) 2011-03-30 22:36:22 PDT
Comment on attachment 511109 [details] [diff] [review]
no hardcoded softfp flag

obsolete
Comment 9 Oleg Romashin (:romaxa) 2011-04-17 09:43:53 PDT
Created attachment 526595 [details] [diff] [review]
Detect HRDFP in configure and disable softfp only in that case
Comment 10 Oleg Romashin (:romaxa) 2011-04-17 09:44:59 PDT
sounds like bug 626035 does not have good progress...
Can we apply this patch (it should be safe for maem/android) and not required any mozconfig changes
Comment 11 Mike Hommey [:glandium] 2011-04-17 23:55:40 PDT
Comment on attachment 526595 [details] [diff] [review]
Detect HRDFP in configure and disable softfp only in that case

I think what we need is a configure flag, e.g --with-arm-float-abi, passing its value to -mfloat-abi when there is one, and with appropriate defaults for the different platforms. This is the way forward for bug 626035 as well (comment 50).
Comment 12 Mike Hommey [:glandium] 2011-12-22 02:09:17 PST
I'm pretty sure this is not an issue anymore with the various changes that happened to the build system (and Debian packages do build fine on armhf)
Comment 13 pbrobinson 2011-12-22 02:46:50 PST
looking at xulrunner 9 in Fedora all the options look to be there in configure to set all the various hard/soft and the type of FP unit.

Note You need to log in before you can comment on or make changes to this bug.