Crash [@ nsGfxScrollFrameInner::BuildDisplayList(nsDisplayListBuilder*, nsRect const&, nsDisplayListSet const&) ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
It is a residual crash signature in 3.6 and the trunk, but there is a small spike in crashes from 4.0b12pre/20110207.

Signature	nsGfxScrollFrameInner::BuildDisplayList(nsDisplayListBuilder*, nsRect const&, nsDisplayListSet const&)
UUID	8816ba10-66dd-426d-bb0e-410d92110208
Time 	2011-02-08 07:31:48.951550
Uptime	38
Last Crash	76971 seconds (21.4 hours) before submission
Install Age	38 seconds since version was first installed.
Product	Firefox
Version	4.0b12pre
Build ID	20110208030358
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0xffffffffdc0488d4
User Comments	
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9505, AdapterDriverVersion: 8.812.0.0

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsGfxScrollFrameInner::BuildDisplayList 	layout/generic/nsGfxScrollFrame.cpp:1896
1 	xul.dll 	nsXULScrollFrame::BuildDisplayList 	layout/generic/nsGfxScrollFrame.h:577
2 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1749
3 	xul.dll 	nsBoxFrame::BuildDisplayList 	layout/xul/base/src/nsBoxFrame.cpp:1317
4 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1706
5 	xul.dll 	nsBoxFrame::BuildDisplayList 	layout/xul/base/src/nsBoxFrame.cpp:1317
6 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1706
7 	xul.dll 	nsBoxFrame::BuildDisplayList 	layout/xul/base/src/nsBoxFrame.cpp:1317
8 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1706
9 	xul.dll 	nsBoxFrame::BuildDisplayList 	layout/xul/base/src/nsBoxFrame.cpp:1317
10 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1706
11 	xul.dll 	nsBoxFrame::BuildDisplayList 	layout/xul/base/src/nsBoxFrame.cpp:1317
12 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1706
13 	xul.dll 	nsDeckFrame::BuildDisplayListForChildren 	layout/xul/base/src/nsDeckFrame.cpp:248
14 	xul.dll 	nsBoxFrame::BuildDisplayList 	layout/xul/base/src/nsBoxFrame.cpp:1317
15 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1706
16 	xul.dll 	nsBoxFrame::BuildDisplayList 	layout/xul/base/src/nsBoxFrame.cpp:1317
17 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1704
18 	xul.dll 	nsBoxFrame::BuildDisplayListForChildren 	layout/xul/base/src/nsBoxFrame.cpp:1355
19 	xul.dll 	nsRootBoxFrame::BuildDisplayList 	layout/xul/base/src/nsRootBoxFrame.cpp:250
20 	xul.dll 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1706
21 	xul.dll 	nsIFrame::BuildDisplayListForStackingContext 	layout/generic/nsFrame.cpp:1455
22 	xul.dll 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1433
23 	xul.dll 	PresShell::Paint 	layout/base/nsPresShell.cpp:6174
24 	xul.dll 	mozilla::widget::GfxInfo::GetFeatureStatusImpl 	
25 	xul.dll 	nsViewManager::RenderViews 	view/src/nsViewManager.cpp:458

The regression range for the spike could be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5bf94fcd5115&tochange=4c62984f12d1
It could be caused by bug 508816.

More reports at:
https://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsGfxScrollFrameInner%3A%3ABuildDisplayList%28nsDisplayListBuilder*%2C%20nsRect%20const%26%2C%20nsDisplayListSet%20const%26%29
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsGfxScrollFrameInner::BuildDisplayList(nsDisplayListBuilder*, nsRect const&, nsDisplayListSet const&) ]

Comment 1

7 years ago
Still a crash in recent versions.

+ 51 crashes on 8.0.1 so far.
+ 319 crashes on 7.0.1 in the past 4 weeks. Not appearing in the top 300.

Updated

3 years ago
Crash Signature: [@ nsGfxScrollFrameInner::BuildDisplayList(nsDisplayListBuilder*, nsRect const&, nsDisplayListSet const&) ] → [@ nsGfxScrollFrameInner::BuildDisplayList(nsDisplayListBuilder*, nsRect const&, nsDisplayListSet const&) ] [@ nsGfxScrollFrameInner::BuildDisplayList ]
Based on the fact that the crash reports are not encounter in the last 28 days on the latest versions (Firefox release, Beta, Aurora, Nightly), therefore closing this bug as Resolved: Works for me. Please reopen the bug if the crash still reproduces and provide more information.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.