unreckognized timezone stops calendar loading

RESOLVED DUPLICATE of bug 632352

Status

Calendar
General
--
major
RESOLVED DUPLICATE of bug 632352
7 years ago
7 years ago

People

(Reporter: Miquel van Smoorenburg, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_6; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7

I added a new caldav calendar, but I only saw 2 events in the calendar while I know I have lots. I can add events from within lightning, but they do not show up in lighting. I can see them in iCal, though.

It turns out that (at least) one calendar entry from the caldav calendar has an unreckognized timezone, and when trying to warn about that lightning dies. Commenting out the warning part from the code makes it all work again.

Reproducible: Always

Steps to Reproduce:
1. Add caldav calendar with entries with unreckognized timezone

Actual Results:  
Calendar shows up partially

Expected Results:  
Should see all entries in calendar

(full error is lower down)

PATCH that "fixes" the problem:

--- calIcsParser.js.ORIG	2011-02-09 23:20:13.000000000 +0100
+++ calIcsParser.js	2011-02-09 23:20:06.000000000 +0100
@@ -207,11 +207,12 @@
         // Use an alert rather than a prompt because problems may appear in
         // remote subscribed calendars the user cannot change.
         if (Components.classes["@mozilla.org/alerts-service;1"]) {
-            let notifier = Components.classes["@mozilla.org/alerts-service;1"]
-                                     .getService(Components.interfaces.nsIAlertsService);
-            let title = calGetString("calendar", "TimezoneErrorsAlertTitle")
-            let text = calGetString("calendar", "TimezoneErrorsSeeConsole");
-            notifier.showAlertNotification("", title, text, false, null, null, title);
+	    // XXX mikevs 08-Feb-2011
+            //let notifier = Components.classes["@mozilla.org/alerts-service;1"]
+            //                         .getService(Components.interfaces.nsIAlertsService);
+            //let title = calGetString("calendar", "TimezoneErrorsAlertTitle")
+            //let text = calGetString("calendar", "TimezoneErrorsSeeConsole");
+            //notifier.showAlertNotification("", title, text, false, null, null, title);
         }
         break;
     }


ERROR FROM Error Console:

Error: Unknown timezone "(GMT+01.00) Berlin/Stockholm/Rome/Bern/Vienna" in "IT Roadmap".  Treated as 'floating' local timezone instead: October 28, 2010 10:00 AM
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VEVENT
CREATED:20101024T122959Z
LAST-MODIFIED:20101024T122959Z
DTSTAMP:20101023T143557Z
UID:{83CEA7D8-93FD-4114-8E98-095E98A996CD}
SUMMARY:IT Roadmap
PRIORITY:5
STATUS:CONFIRMED
ORGANIZER;CN=Arndt:mailto:mdbu@x4l.nn
ATTENDEE;RSVP=TRUE;CN=Rad Rns;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIP
 ANT:mailto:rns@x4l.nn
ATTENDEE;PARTSTAT=ACCEPTED;ROLE=OPT-PARTICIPANT:mkv@x4l.nn
DTSTART;TZID=(GMT+01.00) Berlin/Stockholm/Rome/Bern/Vienna:20101028T100000

DTEND;TZID=(GMT+01.00) Berlin/Stockholm/Rome/Bern/Vienna:20101028T120000
LOCATION:Projectenkamer 6e verdieping (6.02)
DESCRIPTION:Allen\, \n\nGraag deze tijd reserveren
SEQUENCE:4
TRANSP:OPAQUE
X-MICROSOFT-CDO-BUSYSTATUS:BUSY
X-MICROSOFT-CDO-INSTTYPE:0
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-OWNERAPPTID:-1
X-MICROSOFT-CDO-APPT-SEQUENCE:4
X-MICROSOFT-CDO-ATTENDEE-CRITICAL-CHANGE:20101022T144822Z
X-MICROSOFT-CDO-OWNER-CRITICAL-CHANGE:20101023T143557Z
X-MICROSOFT-CDO-REPLYTIME:20101024T122959Z
END:VEVENT
END:VCALENDAR


Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///Users/mikevs/Library/Thunderbird/Profiles/8blx4j5t.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mikevs/Library/Thunderbird/Profiles/8blx4j5t.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calIcsParser.js :: ip_processIcalComponent :: line 212"  data: no]
Source File: file:///Users/mikevs/Library/Thunderbird/Profiles/8blx4j5t.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mikevs/Library/Thunderbird/Profiles/8blx4j5t.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calIcsParser.js
Line: 212


Error: response is not defined
Source File: file:///Users/mikevs/Library/Thunderbird/Profiles/8blx4j5t.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///Users/mikevs/Library/Thunderbird/Profiles/8blx4j5t.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavCalendar.js
Line: 798

Warning: CalDAV: Fatal Error doing webdav sync for lnrar.net
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 632352

Comment 2

7 years ago
I also reproduced the problem with the event described.
the problem seems to be a problem in timezone DTSTART and DTEND.
i think Lightning can not process DTSTART and DTEND correctly because component TIMEZONE is needed in this case.
You need to log in before you can comment on or make changes to this bug.