[regression] Text rendering looks scaled

RESOLVED FIXED in mozilla2.0b12

Status

()

Core
Layout
P1
critical
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Stuart Parmenter, Assigned: roc)

Tracking

({regression})

unspecified
mozilla2.0b12
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+, fennec2.0b5+)

Details

(Whiteboard: [hardblocker])

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
When loading Google News on Android now, our text renders very poorly and looks like it is being bitmap scaled rather than drawn at the correct size.
(Reporter)

Comment 1

7 years ago
Created attachment 511244 [details]
screenshot
(Reporter)

Updated

7 years ago
tracking-fennec: --- → 2.0b5+
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Keywords: regressionwindow-wanted
I'm seeing this in a Linux desktop Fennec build too.
Keywords: regression
OS: Android → All
Hardware: ARM → All
Created attachment 511251 [details]
side by side screenshot

here are screenshots from yesterday and today side by side

Updated

7 years ago
Priority: -- → P1

Comment 4

7 years ago
Trying nightlies:

7th - fonts ok
8th and 9th - I can't run them on my device due to bug 632908
10th - fonts are bad

P.S. Comparing builds with dougt, at one point yesterday we were building the exact same changesets, but I was seeing the bug and dougt was not. Only difference we could see in the build settings was my build was a debug one. Very odd.
I can see this in desktop in a build from m-c 682d008059c6 (afternoon on 2/9).  I'm starting a bisect to narrow down the regression range.
My bisect isn't finished, but I've narrowed it down to this range:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ffe65159d&tochange=d0ea866f

so it looks like bug 586683 is the culprit.
Blocks: 586683
My bisect says that http://hg.mozilla.org/mozilla-central/rev/b0512b9a8c11 is the first bad revision.  I suspect this is incorrect, since it looks like that changeset should not alter any behavior; perhaps I mis-marked one of the revisions that I tested.  The regression range was definitely somewhere within bug 586683, however.
Created attachment 511513 [details] [diff] [review]
fix?

Does this fix it?
Assignee: nobody → roc
Yes, attachment 511513 [details] [diff] [review] fixes the bug for me.
Attachment #511513 - Flags: review?(jones.chris.g)
Attachment #511513 - Flags: review?(jones.chris.g) → review+
blocking2.0: ? → final+
Keywords: checkin-needed

Updated

7 years ago
Keywords: regressionwindow-wanted
Whiteboard: [hardblocker]
Whiteboard: [hardblocker] → [hardblocker][needs landing]
Writing a reftest for this is a bit tricky.  It would be very easy to extend bug 624636 to allow setting content resolution, but it would take a fair amount of new code to allow setting a view transform in the browser, on the shadow layers.  There's probably a cleverer way to check this with only the content resolution and maybe CSS transforms.  Homework problem!

Updated

7 years ago
Whiteboard: [hardblocker][needs landing] → [hardblocker][needs landing][has patch]

Comment 11

7 years ago
http://hg.mozilla.org/mozilla-central/rev/9e8f138a8b9e
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [hardblocker][needs landing][has patch] → [hardblocker]
Target Milestone: --- → mozilla2.0b12
You need to log in before you can comment on or make changes to this bug.