Closed Bug 633060 Opened 11 years ago Closed 11 years ago

[Fx4Launch] Set up billboard for major update to Firefox 4.0

Categories

(www.mozilla.org :: General, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nthomas, Assigned: jlong)

References

()

Details

AFAIK there isn't a billboard ready to offer Firefox 4.0 to 3.5 & 3.6 users, and we'll need one if we are to have that major update available on 4.0's release day (for manual checks only). By convention, the URL should be
  http://www.mozilla.com/en-US/firefox/4.0/details/
It should say some cool things about Firefox 4.0 to 'sell' it, bearing in mind we'll probably use the same billboard when prompting users to upgrade to 4.0. 

We've localised these in the past so need some time to get that done when en-US is finalised.
This is to fit the smaller sized dialog for older releases, rather than the large one for 4.0.
(In reply to comment #1)
> This is to fit the smaller sized dialog for older releases, rather than the
> large one for 4.0.

Can you give me a sample URL for a past example that's relevant to how this one will be done? That'd be a great starting point.

(In reply to comment #0)
> We've localised these in the past so need some time to get that done when en-US
> is finalised.

Can I get a specific date? That'd really help me balance this out vs everything else going on (am juggling a ton of Fx4 stuff already).
Assignee: nobody → jslater
Hardware: x86 → All
(In reply to comment #2)
> Can you give me a sample URL for a past example that's relevant to how this one
> will be done? That'd be a great starting point.

You could look at the history for http://www.mozilla.com/en-US/firefox/3.6/details/ - as you know we keep revising that based on survey results and context, but an early revision might provide some help. IIRC we started with a marketing focus (incentives like new features, speed etc), then got more aggressive about security as we wanted to retire a branch.
 
> Can I get a specific date? That'd really help me balance this out vs everything
> else going on (am juggling a ton of Fx4 stuff already).

I think we will want this for the day we ship Firefox 4.0, based on what we did for 3.6. Christian is the guy to make that call, I filed it because I was preparing a test update for QA and noticed we don't have a page for us to load in the update dialog. 

If it comes down to a crunch we may be able to defer a billboard to the point we actually want to pop an update dialog into users faces (aka 'advertise the update'), which history suggests would be after 4.0.1 or 4.0.2. It should be possible to configure the update to show a plain update dialog in the meantime, possibly at the cost of converting less people over. I'll defer to Christian on that.
Got it. Christian, let me know what you think about the date. I need to juggle this with a bunch of other release-dependent work, and knowing the date the copy is needed (rather than the release date, which I know we don't know yet) is really key for my planning.
We should have this ready for 3/15
Is this a launch blocker? Should be pretty straightforward but I'm wondering how to prioritize this vs the other remaining site bugs for the release.
>We've localised these in the past so need some time to get that done when en-US
is finalised.

Reminder that any translation impacting *all* of our locales has to be started several weeks in advance...
(In reply to comment #5)
> We should have this ready for 3/15

Then we should start on it in the next day or so.

When we release, we will have the MU live. If users on older builds "Check for Updates" they will see a popup with this page.

So this should be fairly high priority but if there are *much* higher priorities we might be able to cope with manually altering the snippets to not pop up the dialog. I'd prefer not to do so as it adds risk and makes qualification take longer, which in turns delays the build being released due to mechanics.

Of course, the page would still need to be started around the same time as release anyway as we push the advertised/prompted update out a couple of weeks after final.

My apologies for this getting dropped, I spaced that the dialog still shows up when manually checking for updates and thought this could get taken care of once all the release pages were settling down / finished.

The dimensions for the page should be the same as in bug 615751.
In the spirit of knocking this out quickly, here's some proposed copy. Mayumi & others, let me know what you think:

Firefox 4 is Here!
_Quick, easy and free update_

* Fresh new look
* 6x faster than Firefox 3.6
* More awesomeness than ever
+1 John's copy.  If "awesomeness" is hard to translate then the more generic message for the last one could be "Exciting new features"
Works for me. Unless there are any immediate objections, let's go with this:

Firefox 4 is Here!
_Quick, easy and free update_

* Fresh new look
* 6x faster than Firefox 3.6
* Exciting new features

Steven, can you put this into the design template we've used before? Should be pretty straightforward, although I'd recommend using the new background gradient now.
Assignee: jslater → steven
Priority: -- → P1
Target Milestone: --- → 1.4
Summary: Set up billboard for major update to Firefox 4.0 → [Fx4Launch] Set up billboard for major update to Firefox 4.0
I'll insert my usual request to drop the urlification of 'Quick, easy, and free update' to mozilla.com, which gives people a path out of the quick and easy way to upgrade using the updater.
Please confirm the text copy this morning so as that I start the translation of this project for all of our 3.6 locales. Thanks
I'm assuming this is based on the smaller billboard size from the 3.6 and older releases, not the awesome new huge one from the 4.0 betas (http://www.mozilla.com/en-US/firefox/4.0beta/details/).

This is setup in the firefox4 branch in r83935.
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: qawanted
Resolution: --- → FIXED
(In reply to comment #12)
> I'll insert my usual request to drop the urlification of 'Quick, easy, and free
> update' to mozilla.com, which gives people a path out of the quick and easy way
> to upgrade using the updater.

Haven't we usually kept the link there? I don't have a strong preference either way, but would prefer to follow precedent given the short turnaround here.

(In reply to comment #13)
> Please confirm the text copy this morning so as that I start the translation of
> this project for all of our 3.6 locales. Thanks

Confirmed.

(In reply to comment #14)
> This is setup in the firefox4 branch in r83935.

http://www-fx4.stage.mozilla.com/en-US/firefox/4.0/details/ looks great to me, thanks for the fast work here.
Hey guys. Pascal just pointed out to me that this page is 404'ing now. Any ideas as to what's going on?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
James merged the content of stage into the firefox4 branch so we hit a rule that redirects all the 4.0 content into the 4.0rc1 directory.

Removed with r84843. Should be ok now.
Thanks guys. Re-resolving...
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Could we make http://www.mozilla.com/en-US/firefox/4.0/details/ work before 4.0 final ships ? That would be very helpful for QA to test major updates. We're already pretty good for the popular locales.

Pascal tells me we're currently redirecting URLs like that to 4.0rc1, and from what I know of the website r84843 looks like a change to go live on 4.0 release day. Could we copy the en-US snippet content over to 4.0rc1/ rather than futz with rewrites ?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reassigning to James to get this pushed to production (based on Comment #20).

James, the page was all setup in trunk in r83935
Assignee: steven → jlong
merged into stage r85037 and r85039
committed to production in r85041
http://www.mozilla.com/en-US/firefox/4.0/details/
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
verified fixed http://www.mozilla.com/en-US/firefox/4.0/details/
Status: RESOLVED → VERIFIED
Thanks a lot guys.
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.