signal name `text_changed::insert:system' is invalid for instance xxxxxxxx

RESOLVED DUPLICATE of bug 631026

Status

()

RESOLVED DUPLICATE of bug 631026
8 years ago
8 years ago

People

(Reporter: ginnchen+exoracle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Start Firefox, sometimes I see this warning.
It seems it is a recent regression.

I caught a stack when I open Pref dialog.

Current function is nsAccessibleWrap::FireAtkTextChangedEvent
 1366       g_signal_emit_by_name(aObject, signal_name, start, length);

(dbx 16) where 20 
current thread: t@1
  [1] g_logv(0xfed7a414, 0x10, 0xfed79470, 0x804683c), at 0xfe941d1c 
  [2] g_log(0xfed7a414, 0x10, 0xfed79470, 0xfed79460, 0x9a3a4f8, 0x94fc278, 0x804685c, 0x1), at 0xfe942210 
  [3] g_signal_emit_by_name(0x94fc278, 0x9a3a4f8, 0x9, 0x1, 0x0, 0x0), at 0xfed65bde 
=>[4] nsAccessibleWrap::FireAtkTextChangedEvent(this = 0x99c0a60, aEvent = 0xaeb6f00, aObject = 0x94fc278), line 1366 in "nsAccessibleWrap.cpp"
  [5] nsAccessibleWrap::FirePlatformEvent(this = 0x99c0a60, aEvent = 0xaeb6f00), line 1082 in "nsAccessibleWrap.cpp"
  [6] nsAccessibleWrap::HandleAccEvent(this = 0x99c0a60, aEvent = 0xaeb6f00), line 1049 in "nsAccessibleWrap.cpp"
  [7] nsEventShell::FireEvent(aEvent = 0xaeb6f00), line 63 in "nsEventShell.cpp"
  [8] nsDocAccessible::ProcessPendingEvent(this = 0x99c0a60, aEvent = 0xaeb6f00), line 1714 in "nsDocAccessible.cpp"
  [9] NotificationController::WillRefresh(this = 0x96bb098, aTime = CLASS), line 310 in "NotificationController.cpp"
  [10] nsRefreshDriver::Notify(this = 0x8e87ee0, _ARG2 = 0x95bce58), line 254 in "nsRefreshDriver.cpp"
  [11] nsTimerImpl::Fire(this = 0x95bce58), line 428 in "nsTimerImpl.cpp"
  [12] nsTimerEvent::Run(this = 0x96b5c88), line 517 in "nsTimerImpl.cpp"
  [13] nsThread::ProcessNextEvent(this = 0x80dca80, mayWait = 1, result = 0x8046ee4), line 633 in "nsThread.cpp"
  [14] NS_ProcessNextEvent_P(thread = 0x80dca80, mayWait = 1), line 250 in "nsThreadUtils.cpp"
  [15] nsBaseAppShell::Run(this = 0x81d7c38), line 195 in "nsBaseAppShell.cpp"
  [16] nsAppStartup::Run(this = 0x83ea578), line 220 in "nsAppStartup.cpp"
  [17] XRE_main(argc = 1, argv = 0x8047548, aAppData = 0x8065e20), line 3766 in "nsAppRunner.cpp"
  [18] main(argc = 1, argv = 0x8047548), line 158 in "nsBrowserApp.cpp"

(dbx 17) f 4
Current function is nsAccessibleWrap::FireAtkTextChangedEvent
 1366       g_signal_emit_by_name(aObject, signal_name, start, length);
(dbx 18) p aObject
aObject = 0x94fc278
(dbx 19) p *aObject
*aObject = {
    parent            = {
        g_type_instance = {
            g_class = 0x9501570
        }
        ref_count       = 2U
        qdata           = (nil)
    }
    description       = (nil)
    name              = 0x99b57f8 "Minefield Preferences"
    accessible_parent = 0x8abf4a0
    role              = ATK_ROLE_DIALOG
    relation_set      = 0x8a8aa90
    layer             = ATK_LAYER_INVALID
}
(dbx 20) p signal_name 
signal_name = 0x9a3a4f8 "text_changed::insert:system"
(dbx 21) c

(firefox-bin:13805): GLib-GObject-WARNING **: gsignal.c:3079: signal name `text_changed::insert:system' is invalid for instance `94fc278'

I think we should not fire text_changed for ROLE_DIALOG.

Surkov, why we are here?

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 631026
You need to log in before you can comment on or make changes to this bug.