Closed Bug 633068 Opened 12 years ago Closed 12 years ago

Switch to fullscreen instantly with no animation. Get rid up the top hover also while in fullscreen.

Categories

(Firefox :: General, enhancement)

All
Windows 7
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 423014

People

(Reporter: warcraftthreeft, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Ideally the best scenario is no bar at the top in fullscreen. However, something like what Chrome does would be nice. That is when in fullscreen a semi-transparent reminder should overlay the top of the page to remind the user how to exit fullscreen. The change though that chrome doesn't do yet is to allow the user to exit out of that reminder and leave the user in fullscreen mode.

The reason to remove the initial animation to fullscreen is the resize event. Only a single resize event should be invoked by the user-agent when switching to fullscreen to make the transition quick and efficient. When switching out of fullscreen a single resize event should be used again. You shouldn't have to write debounce code.

Reproducible: Always

Steps to Reproduce:
1. Push f11
2. Notice the animation and resize events.
Actual Results:  
Animation tries to play out as the page is resized. This invokes resize events multiple times to the page.

Expected Results:  
Pushing f11 should go to a fullscreen view instantly with no animation.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.