video stops when scrolling down the page by mouse wheel

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Alex Leung, Unassigned)

Tracking

4.0 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre

The video is stopped (but audio is not stopped) when i scroll down the page by turning the mouse wheel 3 clicks. (2 and 4 clicks works, just 3 clicks doesn't)

Reproducible: Always

Steps to Reproduce:
1.go the the url
2.play the video
3.scroll down the page by turning the mouse wheel 3 clicks
Actual Results:  
the video stops but audio is playing.

Expected Results:  
video plays as usual.

Comment 1

8 years ago
Works for me

Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre
(Reporter)

Comment 2

8 years ago
my mouse is a logitech G5
(Reporter)

Comment 3

8 years ago
Created attachment 511314 [details]
the exact position that the video is not working
(Reporter)

Comment 4

8 years ago
(In reply to comment #1)
> Works for me
> 
> Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre

please check the attachment.

Comment 5

8 years ago
I have played the entire video through at the position that you have specified (3 mouse wheel clicks down). The video is right under the bookmarks bar and it does not freeze for me.
(Reporter)

Comment 6

8 years ago
64bit build specific? btw, the flash version is 10.3.162.28 "square" preview 3

Comment 7

8 years ago
I am running 32 bit with 10.2 flash. Try downgrading your flash and see if it still occurs.

Comment 8

8 years ago
TopGear UK?

It looks like video player could use some code from BBC iplayer then look:

Bug 628872 - BBC iplayer fullscreen function broken in FF4 beta 9, 10 and nightly builds 

and look what other regressions are introduced when messing with patch trying fix above bug (Bug 631544, Bug 631794, Bug 631872) Sounds very related to me.

Comment 9

8 years ago
Okay Alex I can confirm this bug, but not on your URL.

I just experienced this bug with this page: http://www.gamespot.com/pc/rpg/unnameddragonageprojectworkingtitle/video/6298174?hd=1

You'll have to scroll up and down a bit until it freezes.

Comment 10

8 years ago
Ok I can confirm on:

http://www.topgear.com/uk/videos?VideoBrowserMode=categories&VideoCategory=Tests

Video still play, but scrolling of page sometimes freeze when using mouse wheel (press scroll button, then scroll page).

Windows 7 32 bit, Flash Player 10.2.152.26

Comment 11

8 years ago
Similar bug: https://bugzilla.mozilla.org/show_bug.cgi?id=631872  ?

Comment 12

8 years ago
Confirm this bug for me.
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre ID:20110209030359

Also see in this bug for BBC player: https://bugzilla.mozilla.org/show_bug.cgi?id=628872

FLASH
Shockwave Flash

    Fișier: NPSWF32.dll
    Versiune: 10.2.152.26
    Shockwave Flash 10.2 r152

Tip MIME 	Descriere 	Sufixe
application/x-shockwave-flash 	Adobe Flash movie 	swf
application/futuresplash 	FutureSplash movie 	spl
Shockwave for Director

    Fișier: np32dsw.dll
    Versiune: 11.5.9.620
    Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620

Tip MIME 	Descriere 	Sufixe
application/x-director 	Shockwave Movie 	dir,dxr,dcr

Comment 13

8 years ago
(In reply to comment #10)
> Ok I can confirm on:
> 
> http://www.topgear.com/uk/videos?VideoBrowserMode=categories&VideoCategory=Tests
> 
> Video still play, but scrolling of page sometimes freeze when using mouse wheel
> (press scroll button, then scroll page).
> 
> Windows 7 32 bit, Flash Player 10.2.152.26

This is not related to the bug. The bug is talking about how the video FREEZES not the scrolling of the page.

(In reply to comment #11)
> Similar bug: https://bugzilla.mozilla.org/show_bug.cgi?id=631872  ?

This is not related either. We're not talking about scroll focus, we're talking about repaint issues with the flash plugin.

(In reply to comment #12)
> Confirm this bug for me.
> Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre
> ID:20110209030359
> 
> Also see in this bug for BBC player:
> https://bugzilla.mozilla.org/show_bug.cgi?id=628872
> 
> FLASH
> Shockwave Flash
> 
>     Fișier: NPSWF32.dll
>     Versiune: 10.2.152.26
>     Shockwave Flash 10.2 r152
> 
> Tip MIME     Descriere     Sufixe
> application/x-shockwave-flash     Adobe Flash movie     swf
> application/futuresplash     FutureSplash movie     spl
> Shockwave for Director
> 
>     Fișier: np32dsw.dll
>     Versiune: 11.5.9.620
>     Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
> 
> Tip MIME     Descriere     Sufixe
> application/x-director     Shockwave Movie     dir,dxr,dcr

Please refrain from posting unrelated bugs into other bugs and asking people to confirm them. This is not how bugzilla works.
(Reporter)

Comment 14

8 years ago
Benjamin, are you still having issues with your URL in latest nighties? the URL in my report magically worked in Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre and i can't reproduce the problem in your provided URL.

Updated

7 years ago
Version: unspecified → 4.0 Branch
This is WFM against Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1 ID:20110413222027 + Flash 10.3.181.14.
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco

Comment 17

7 years ago
I can't seem to reproduce with any of the URLs in the latest Nightly build.
(Reporter)

Comment 18

7 years ago
since none of us can reproduce the problem with the latest nightly, i've marked this bug as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.