Firefox 4 beta 11 turned into a black screen overnight

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Stormy Peters, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(6 attachments)

(Reporter)

Description

7 years ago
Created attachment 511366 [details]
Screen shot of Firefox 4 beta 11 as an all black screen

I left Firefox 4 beta 11 running all night. In the morning, it showed me a title bar and a black screen. I could open a new window but I could not do anything with the existing window (and the tabs that were supposedly in it.)

I attached a screenshot.
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Hardware: x86 → All
Version: unspecified → Trunk
(Reporter)

Comment 1

7 years ago
FYI. I installed Firefox 4 beta 11 3 days ago. I also installed Google Chrome at the same time. I left Firefox running all night every night. (Chrome was only running one of those nights.) I did not install or uninstall anything else and did not use my computer differently than normal.

The first night my computer hung.
The second night Firefox was the black screen you see attached here.
The third night, Firefox was running, and the menus worked, but I could not change tabs and while I could click in fields in my open tab, I could not type anything and clicks did not do anything but change the focus to that field. (Clicking on links did not change pages.)

(Firefox also crashes during the day. Once already, but does not freeze like it does when left overnight.)
I see this all the time now with certain tracemonkey opt+symbols dogfood builds I make. I thought it might be the 64-bit Flash beta I had, which Adobe revoked, but I've disabled Flash.

I also get artifacts (sometimes the whole screen becomes an abstract-expressionist version of various tiled pieces from several apps windows. Bug 635373 ?

Sometimes cmd-tab'ing around clears things up. The black window, not so much - -but scrolling that window can!

This seems very bad. I replaced an MBP after colleagues all said they had not seen the like, and it must be hardware. It smells like GPU misprogramming. I thought we used vanilla OS APIs (coregraphics), are they unreliable?

/be
Stormy, did your problems reported here go away?

/be
blocking2.0: --- → ?
What does about:support say about your graphics acceleration? (bottom of the page)

If it shows accelerated windows, can you try turning off acceleration (prefs -> advanced -> browsing) and see if it stops happening?
Stormy: can you drop the crash URLs in here for the recent crashes? you can find them in about:crashes.
Graphics
      
      
      
        
        Adapter Description0x22600,0x20400Vendor ID0000Device ID0000Adapter RAMAdapter DriversDriver VersionDriver DateDirect2D EnabledfalseDirectWrite EnabledfalseWebGL RendererNVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine -- 2.1 NVIDIA-1.6.26GPU Accelerated Windows11/11 OpenGL


I tried turning off acceleration with the previous MBP and it did not help. I'll try again. Desperate here.

/be
Are these computers being left open (running) or closed (asleep)?
Open all the time.

/be
Accleration off and I just clicked on a link in IRC and got a black window. Maybe I should reboot...

/be
OS: Mac OS X → Windows 7
Stormy's problem is on OS X. Either this is cross-platform, in which case it's less likely to be graphics related, or you're seeing a different problem.
I am on OS X (MBP = MacBook Pro).

/be
Sorry for bad formatting in comment 6 -- I just copied and pasted.

Joe, what in that comment made you think I was not on Mac?

/be
(Reporter)

Comment 13

7 years ago
I haven't gotten the black window again but the screen does freeze still occasionally. Although most of the crashes listed below are freezes with pinwheels, not the frozen screen.

I'm not sure what timezone the crashes are in but the 2/10 one is the black screen one. 2/9 was frozen in the morning. 2/11 was the day it let me click on things and open menus, but nothing reacted. The more recent ones have all been pinwheel hangs, not frozen screens.

My computer was left open and running attached to a monitor. 

C21AA2D9-71B8-4D9B-B702-0AB7A27646D6   2/17/11 12:42 
AM77D2046C-D6DF-4C9A-9978-E92E958597C8  2/17/11 12:41 
AMB734D7FE-3FAD-4274-800B-0FAE75FFB83F  2/15/114:33 
AM5D4F5C6F-3573-4B1C-9E93-16ADA2AE0917 2/15/114:31 
AM407C1670-709D-48B4-A940-94924ED3360D 2/14/112:56 
AM3FA57C3F-F32F-482A-BEE2-35D665A21587 2/14/112:56 
AMbp-7ca798ab-177f-48ce-8bfd-454502110213 2/13/112:16 
PMF508C1F5-0E14-41BA-9097-498181632F9A 2/12/1112:35 
AM60DDE462-5AFC-4FC4-9373-96C8DCCB644C 2/12/11 12:33 
AMbp-a356c3ca-2006-42af-8e28-b37112110211 2/11/11 10:26 
AMC70EC925-53C0-40C4-8C57-D514FF0FD28F 2/11/11 1:05 
AM074AC1C0-C34E-462B-8813-571EE14937F5 2/11/11 1:04 
AM6393E22A-4F98-4395-82E4-E260DAD89DB4 2/10/11 1:12 
AM04960A60-CF73-45A5-A9DA-1C246915C9A8 2/10/11 1:11 
AM9606E255-C3A5-4DC0-ABBE-33DF1C6B87E9 2/8/111:14 
AM6E1E208C-F229-4620-8496-BB6F5EF902F6 2/8/111:14 
AM6E208CEE-90F8-46C7-8198-98126DE03A87 2/7/113:34 
AMEDB7F1D8-F8BB-4C4F-9237-DA3C17D3D350 2/7/113:34 
AMbp-53f97ced-c2fa-4d32-833a-3fb342110206 2/6/111:29 
PM653D2EC5-262D-4045-89CC-A5A7B7C80685 2/6/111:16 
AMDEF4ACEE-D55B-49C3-A197-E6819E99523B 2/6/111:15 AMbp-4aef4b13-4d82-40f6-8cb5-44c2d2110205 2/5/119:03 
PMbp-c2549a8f-1e42-4970-8f19-f51b02110204 2/4/114:30 PMD9032459-19D0-4E12-98F6-1229303BE07C 2/1/118:43 
AM615EB71B-ABE6-464A-AF3C-24E712C206F5 2/1/118:43
I have no idea how OS just changed to Windows 7. Commenting here with Chrome, I blame it or its kbd nav and form control behavior.

/be
OS: Windows 7 → Mac OS X
Do I need to restart after changing the accelerated graphics pref? Probably, but the pref UI acts as if the effect is applied without confirming steps or restarts.

/be
(Reporter)

Comment 16

7 years ago
My graphics options are:

Adapter Description0x22600,0x20400
Vendor ID0000
Device ID0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabledfalse
DirectWrite Enabledfalse
WebGL RendererNVIDIA Corporation -- NVIDIA GeForce 320M OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows1/1 OpenGL
(I pasted from the bottom of about:support in Chrome after copying in my black-screen-tastic Minefield; Stormy must have copied and pasted in Firefox, cuz comment 16 is nicer -- but when will table data be separated by spaces or tabs instead of run together on paste? Oh well...)
OS: Mac OS X → Windows 7
Yes, you have to restart (or, at minimum, close all your open windows) to disable hardware acceleration.
OS: Windows 7 → Mac OS X
(In reply to comment #18)
> Yes, you have to restart (or, at minimum, close all your open windows) to
> disable hardware acceleration.

Mac pref ui follows HIG (IIRC) and pretends everything is instant-apply or "live update". Could use some clues for the exceptions.

Restarting, will update again if I see black.

/be
Restarting left me with abstract-expressionist-tiled artifacts for multiple apps, cured by cmd-tabbing enough. I will reboot when I can. Question this raises is: could the GPU and OS be left with bad bits even after Minefield exited?

/be
(Reporter)

Comment 21

7 years ago
(I manually edited my about:support options. It was an ugly copy and paste. So was the crash reports page.)

Comment 22

7 years ago
Note: I had for a long time the exact same hardware as brendan and I didn't see this. We might be visiting different sites, or have different extensions/flash.
Created attachment 514541 [details]
saved about:support main page
OS bugs know no bounds.
Created attachment 514543 [details]
aboutSupport.js
Created attachment 514544 [details]
aboutSupport.css
https://input.mozilla.com/en-US/beta/search?q=black+screen&product=firefox&version=4.0b11&date_start=&date_end=&platform=mac

I don't think this is happening commonly enough, but please renominate if we can catch it in a debugger or figure out the cause.
blocking2.0: ? → -
I'm chasing a separate (by symptom: crashes) bug that dvander suspects is a reference-counting problem in exec-pools into which JM uses to compile method-jitted code. One crash showed what appeared to be unmapped memory; another showed memory mapped not-executable. If we underflow a ref-count and munmap memory still in use by the JIT, we'd get the last symptom.

Now consider what might happen if we reallocate that memory to gfx. Seems likely to cause corruption, and in chasing the bug dvander and I are after, I had applied a patch of his to log ref-count ops. Aside from de-inlining, which might dodge compiler bugs on Mac GCC (see bug 634590), this could explain why I suddenly had a notable re-occurrence of black windows and abstract-expressionist painting spaz-outs.

I smell a connection. Without dvander's logging patch, I would crash but I didn't see the black windows. With that patch, I got no crashes but lots of black windows and painting problems (cross-app).

I've rebooted now and I'm rebuilding my tm tip dogfood build. My default profile has acceleration off. I'll see if this helps. I'll also look for a connection with the apparent JM memory management bug.

In that light, Joe, anyone: does gfx code (ours, or Mac OS core graphics, to our knowledge), allocate via mmap(2)?

/be
(In reply to comment #28)
> I'm chasing a separate (by symptom: crashes) bug that dvander suspects is a
> reference-counting problem in exec-pools into which JM uses to compile
> method-jitted code. One crash showed what appeared to be unmapped memory;
> another showed memory mapped not-executable. If we underflow a ref-count and
> munmap memory still in use by the JIT, we'd get the last symptom.

Sorry, should be "we'd get the next-to-last symptom; if the memory is reallocated via mmap for another purpose, we'd get the last symptom".

The bug dvander filed to track JM memory management apparent problems is bug 635968.

/be
(In reply to comment #28)
> In that light, Joe, anyone: does gfx code (ours, or Mac OS core graphics, to
> our knowledge), allocate via mmap(2)?

Ours uses new/malloc(). I have no knowledge of what OpenGL or Quartz use, though.
I'll see if I can find out.
(In reply to comment #28)
> In that light, Joe, anyone: does gfx code (ours, or Mac OS core graphics, to
> our knowledge), allocate via mmap(2)?
> 
> /be

CoreGraphics does.
In fact, OS X uses mmap() to back malloc() for many things, e.g.

#0  0x00007fff88cadea0 in mmap ()
#1  0x00007fff88cadda7 in allocate_pages ()
#2  0x00007fff88cbdeaf in large_malloc ()
#3  0x00007fff88cafc69 in szone_malloc_should_clear ()
#4  0x00007fff88caeeea in malloc_zone_malloc ()
#5  0x00007fff88cad1e8 in malloc ()
#6  0x00007fff80863b73 in gfxAllocateTextureLevel ()
#7  0x000000011bc95700 in glTexImage2D_Exec ()
#8  0x00007fff84872370 in glTexImage2D ()

So you should run into this all over the place if we're munmapping things that we still have in use.
(In reply to comment #32)
> So you should run into this all over the place if we're munmapping things that
> we still have in use.

There's a reproducible (for me) STR over at bug 635968. Could explain a number of crashes, as well as the gfx freak-outs and black windows. Why those are rare (me, Stormy initially) I cannot say, but the web is so big we could all have mostly disjoint session-restored URLs. Then there are add-ons. I'll try to reenable and get the gfx freak-outs to recur, then try safe mode to rule out add-ons.

/be
Note: Safe mode also disables hardware acceleration.
(Reporter)

Comment 35

7 years ago
Is there something I can do to help?
(Reporter)

Comment 36

7 years ago
Now instead of a black screen, I have a title bar, navigation bar and bookmark bar with nothing below that ... It looks really weird.

I have it live on my machine right now if someone would like to look at it. I will leave it up for a bit before I restart FireFox so let me know ...

(Will attach the screenshots now.)
(Reporter)

Comment 37

7 years ago
Created attachment 514890 [details]
title bar, bookmarks with no window body ...
(Reporter)

Comment 38

7 years ago
Created attachment 514892 [details]
title bar, bookmarks with no window body ...
(Reporter)

Comment 39

7 years ago
Ignore my last 3 updates.

Something resized all my windows to be just the size of my tabs/navigation/bookmarks bar.
My gfx woes seem gone with the patch for bug 635968 landing in tm. Yay!

/be
Stormy, have you seen this problem with the latest nightlies (since February 26th)?
(Reporter)

Comment 42

7 years ago
I'm on beta 12 at the moment and I haven't seen the black screen!! My browser did hang last night but it was a regular hang with the pinwheel, not a graphics looking problem.

I can switch to the nightly today and see if it happens tonight.
Yeah, beta 12 doesn't have the fix Brendan was talking about - nightlies would be better to test.
It's baaaack. Both black window (except for titlebar) and gfx freakouts.

I'm running my own opt w/ debug symbols build from the tracemonkey repo, based on

http://hg.mozilla.org/tracemonkey/rev/7f65c1c0cc55

No crashes around method-jitted code lately, one tracejit unmapped-code crash I reported but not with this build. Very strange.

/be
(Reporter)

Comment 45

7 years ago
I haven't seen this problem on the nightlies and Firefox hasn't frozen the last few nights! Yeah!!
(Reporter)

Comment 46

7 years ago
I have not seen this problem on Firefox 4.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.