Closed Bug 633223 Opened 13 years ago Closed 13 years ago

A new AppTab is not created if Drag And Drop a tab from another Browser Window

Categories

(Firefox :: Tabbed Browser, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 590297

People

(Reporter: andrei.domuta, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Chrome/9.0.597.94 Safari/534.13
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre

When having two browser windows open and trying to drag and drop one tab from one window to the other window between two AppTabs, a new tab is created instead of a new AppTab

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox on a new profile
2. Open other 3 different tabs
3. Pin 3 tabs as AppTabs
4. Open a new browser window (ctrl+n on windows) and open a new tab (beside the default one opened)
5. Drag and drop the new opened tab into the other window between 2 AppTabs
Actual Results:  
5.A new tab is created instead of a new AppTab

Expected Results:  
1.Firefox should launch with 2 tabs open (startpage and mozilla page)
2.Five different tabs should be fully loaded
3.Browser window should have 3 AppTabs and 2 normal tabs
4.New browser window should be available with 2 different tabs
5.A new AppTab should be created in the initial browser window
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Version: unspecified → Trunk
I would tend to say dependent or dupe of bug 579482.
I would say that it is more likely a depend, not a dupe.
Lets add dependency for now.
Depends on: 579482
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
No longer depends on: 579482
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.