Regression: iframe panning is broken

VERIFIED FIXED

Status

defect
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: stechz, Assigned: mbrubeck)

Tracking

({regression})

Firefox Tracking Flags

(fennec2.0b5+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
STR:
1. Go to http://people.mozilla.org/~bstover/iframe3.html
2. Go to bottom of page and pan iframe

The iframe appears white, as if it has no content.
tracking-fennec: --- → 2.0b5+
(Assignee)

Updated

8 years ago
Assignee: nobody → mbrubeck
(Assignee)

Comment 1

8 years ago
I still see this after reverting back to http://hg.mozilla.org/mobile-browser/rev/d49b851fe2fc - so it looks like something in platform (mozilla-central) must have broken it.
(Assignee)

Comment 2

8 years ago
I was wrong, this is a regression from bug 628799.  The first bad revision is:
http://hg.mozilla.org/mobile-browser/rev/134e1e507ca3
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
(Assignee)

Comment 3

8 years ago
Posted patch patchSplinter Review
updateCacheViewport need to use the scale of the root content view, regardless of which view we are scrolling.
Attachment #511856 - Flags: review?(ben)
(Reporter)

Updated

8 years ago
Attachment #511856 - Flags: review?(ben) → review+
(Assignee)

Comment 4

8 years ago
http://hg.mozilla.org/mobile-browser/rev/63fbf2c3ca08

Need some tests for this...
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b12pre) Gecko/20110216 Firefox/4.0b12pre Fennec/4.0b5pre


Filed a follow-up issue in bug 634636
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.