Double click in textarea does not select the word if there is a div with contentEditable=true

RESOLVED DUPLICATE of bug 490367

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 490367
7 years ago
7 years ago

People

(Reporter: Jonas von Andrian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

When there is a a single div on the Page with contentEditable set to true no other Textarea processes a double click correctly. Instead of selecting the word under the double click the cursor stays the same.

Triple click works. It selects the whole line.

Reproducible: Always

Steps to Reproduce:
1. Use this minimal html
<html><body>
<form action="#" ><textarea>
test test test
</textarea></form>
<div contenteditable="true" class="preview">
  <h1>Test</h1>
</div></body></html>
2. Double click on words in textfield

Actual Results:  
Cursor stays

Expected Results:  
Word under double click is selected

Firefox 4 Beta 11 behaves the same
Component: Layout: Form Controls → Editor
QA Contact: layout.form-controls → editor

Updated

7 years ago

Comment 1

7 years ago
Confirmed
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre ID:20110210030400

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 490367
You need to log in before you can comment on or make changes to this bug.